Line breaks after LABEL tag?

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
P1
normal
VERIFIED WORKSFORME
18 years ago
4 years ago

People

(Reporter: pete, Assigned: rods (gone))

Tracking

({html4, testcase})

Trunk
Future
x86
All
html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
The <label ...>Search: </label> renders with a line break after it when it's 
not supposed to (at least I and Internet Explorer think so).
Created attachment 11147 [details]
simple testcase
Created attachment 11148 [details]
simple testcase with input (previous had a select)
Created attachment 11149 [details]
simple testcase with label and img in table
I couldn't get this to happen with a SPAN instead of a LABEL -- so I suspect 
that this may have something to do with LABEL's special behavior.  However, it 
could still be a more general table problem.  Assigning to HTML Form Controls, 
but cc:ing karnaze.
Assignee: clayton → rods
Status: UNCONFIRMED → NEW
Component: Layout → HTML Form Controls
Ever confirmed: true
QA Contact: petersen → ckritzer
(Assignee)

Comment 5

18 years ago
I will need buster's help with this one, sounds like a floater issue to me.


This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
(Assignee)

Updated

17 years ago
Summary: Line breaks after LABEL tag? → [LBL]Line breaks after LABEL tag?
(Assignee)

Comment 7

17 years ago
I'll take another look but my guess is that this is a floater problem for buster
Priority: P3 → P1
Target Milestone: Future → ---
(Assignee)

Comment 8

17 years ago
Reassigning to copre layout for a look
Assignee: rods → attinasi
Status: ASSIGNED → NEW
Summary: [LBL]Line breaks after LABEL tag? → Line breaks after LABEL tag?

Comment 9

17 years ago
Rod, what did you learn when you looked at this? Why do you suspect it is a 
floater problem? Does align=right on a TD cause a floater?

Comment 10

17 years ago
Created attachment 26558 [details]
New testcase: no tables, just div with aligh=right

Comment 11

17 years ago
If a DIV with align=right has a LABEL in it, the label seems to act like a
block. I don't know what is up with the LABEL, but like David mentioned, this
does not happen with a simple SPAN. I could see no evidence of any floaters but
clearly we are getting two lines. Rod, if you have any knowledge of the LABEL
and how it behaves it would be appreciated. This may be a block-issue, but it
seems unlikely since the simple SPAN case is no problem.

Comment 12

17 years ago
Rod, this has lots in common with bug 47149 (futured) - Also note the block in 
forms.css that reads:

label {
  /* our <label> support is badly broken. (b=47149) */
  vertical-align: bottom;
  padding-left: 3px;
  padding-right: 3px;
}

sending back to you. My guess is that we will have to work together on this when 
it rises to the top of the priority stack.
Assignee: attinasi → rods
(Assignee)

Comment 13

17 years ago
adding Marc to cc list and futuring until we can figure it out.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 14

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Comment 15

17 years ago
Occurs on Linux too, OS/All. It works fine in quirks mode though (i.e. no line
break is appended to the </label>. HTML4 keyword since I cannot find <label> in
the 3.2 spec.
Keywords: html4
OS: Windows NT → All

Comment 16

17 years ago
Nominating for mozilla1.0.
Keywords: mozilla1.0
All the testcases workforme on Linux 2001-11-01-21.  Is this an issue still on
other OS's?

Comment 18

16 years ago
wfm win32 build 2001102903

maybe related to bug 47149 ?
Closing WORKSFORME, today's Linux CVS.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: testcase
Resolution: --- → WORKSFORME

Comment 20

16 years ago
verifying on 2001-11-19-0.9.4ec
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.