add-ons window freezes when Adblock Plus "option" button is pressed

RESOLVED INCOMPLETE

Status

()

Toolkit
Add-ons Manager
RESOLVED INCOMPLETE
10 years ago
10 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I just installed the new firefox 3.o RC 2 and upon opening the add-ons manager window to remove incompatible add-ons, I noticed that some icons showed incompatibilities, some were compatible, and others were blank.  I clicked on the "option" button for the blank (icon) Adblock Plus add-on and (only) the window for the add-ons manager froze and wouldn't allow me to close it (I got the windows beep that usually indicates a yes/no type message box is open and must be answered immediately, except no such window was running).

Reproducible: Always

Steps to Reproduce:
1.Open the add-ons manager from the tools list in the menu bar
2.find an add-on with a blank icon
3.select the "option" button for that add-on
Actual Results:  
The add-ons manager window froze and beeped when I clicked anywhere in the window.  I have to close the window with the windows task manager.

Expected Results:  
An error message should have popped up and explained some problem with the add-on's compatibility.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008060807 Minefield/3.1a1pre

I see no problem with Adblock Plus version 0.7.5.3. There is even a newer one: https://addons.mozilla.org/en-US/firefox/addon/1865 
Did you try updating your extensions?
(Reporter)

Comment 2

10 years ago
The problem is not with Adblock Plus.  I found that if you install Firefox 3 on top of Firefox 2 (without an uninstall first) then you get the blank icon errors in the add-ons manager.  I tried a clean install by uninstalling Firefox 2 first.  In that situation, I had no trouble with installing and using the new Adblock Plus (as well as other add-ons).  The issue is probably with the Firefox 3 installer.
Component: Extension Compatibility → Extension/Theme Manager
QA Contact: extension.compatibility → extension.manager

Updated

10 years ago
Duplicate of this bug: 438910
Please attach copies of extensions.ini, extensions.cache, extensions.rdf and extensions.log from your profile folder.

http://support.mozilla.com/en-US/kb/Profiles

Comment 5

10 years ago
(In reply to comment #2)

I have had the same problem. Michael I don't think the problem is with any of the extensions themselves. The computer I use that experiences this problem also has Firefox 2 still installed (as a backup). The only difference that I can see in our two bugs is that I have never noticed any blank icons when the error occurs. That may be an error that pertains specifically to Vista, as my error occurred in XP.

I filed my own bug because I didn't see this one earlier. You may find my complete bug notes at the address below:

https://bugzilla.mozilla.org/show_bug.cgi?id=438910
(Reporter)

Comment 6

10 years ago
I've already uninstalled Firefox 2 and then reinstalled Firefox 3.  I didn't have any troubles with the clean Firefox 3 install.  Because of Dave Townsend's post I have reinstalled Firefox 2 from a clean install and then tried reinstalling Firefox 3 over top of the existing Firefox 2 installation with a lot of similar add-ons preinstalled.  Fortunately, at least for Firefox 3 rc 3 (the original post was with rc 2) I no longer had the blank icons in the add-on manager.  I had no more troubles with this bug.  So, perhaps this bug was due to my older add-on versions or Firefox 3 RC 2.  

Comment 7

10 years ago
I'm pretty sure this bug has to do with some sort of redundancy error that comes from having multiple versions of firefox. I just installed the release version of Firefox 3 (without uninstalling my versions of FF2 or FF 3 RC 2), and found both the same bug, and another that appears to be caused by the same error which I'll talk about in a minute. Anyways, I uninstalled both previous versions of firefox and then restarted my computer. Since then, I've had no further problems with this bug.

The other bug I encountered was a failure for updated add-ons to properly update upon restart. The updates would install, and then ask to restart to complete the update. Upon restart, when I opened add-on window, it asked me to again restart to complete the update. Thinking it was a fluke, I tried again. And then 2 more times. After uninstalling and deleting the previous versions of firefox, I have not encountered any further problems.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
I am closing this report as incomplete. The information I requested in comment 4 is really critical to analysing what is going on here. Without that it will be impossible to resolve this. Please reopen if someone experiencing this specific problem can provide that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.