No accept/Decline buttons and NS_ERROR_NOT_INITIALIZED in calIItipItem::getItemList for a particular iTip invitation

RESOLVED FIXED in 1.0b1

Status

RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: altenschmidt, Assigned: dbo)

Tracking

unspecified
1.0b1
x86
Linux
Bug Flags:
wanted-calendar1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Lightning 0.9pre (build 2008060818) on Thunderbird version 2.0.0.14 (20080421)

For a particular iTip invitation for an event unknown to my calendar the Accept/Decline/Tentative buttons won't show up. At the same time the error console gets appended by two errors saying

Error: [Exception... "'Component not initialized' when calling method: [calIItipItem::getItemList]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: chrome://lightning/content/imip-bar.js :: isUpdateMsg :: line 581"  data: no]
Source File: chrome://lightning/content/imip-bar.js
Line: 581

Other iTip invitations, even from the same person with the same calendar client (Evolution), behave as expected. I have appended the broken(?) invitation, with some minor changes to protect the privacy of all involved people:

BEGIN:VCALENDAR
CALSCALE:GREGORIAN
PRODID:-//Ximian//NONSGML Evolution Calendar//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:/softwarestudio.org/Tzfile/Europe/Berlin
X-LIC-LOCATION:Europe/Berlin
BEGIN:STANDARD
TZNAME:CET
DTSTART:19701026T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-2SU;BYMONTH=10
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
END:STANDARD
BEGIN:DAYLIGHT
TZNAME:CEST
DTSTART:19700329T030000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
UID:20080416T074600Z-4375-500-1-124@host
DTSTAMP:20080609T073205Z
DTSTART;TZID=/softwarestudio.org/Tzfile/Europe/Berlin:20080613T160000
DTEND;TZID=/softwarestudio.org/Tzfile/Europe/Berlin:20080613T170000
TRANSP:OPAQUE
SEQUENCE:4
SUMMARY:Job interview: Www Www
CLASS:PUBLIC
ORGANIZER;CN=Xxx Xxx:MAILTO:xxx@xxx.com
CREATED:20080416T075813
LAST-MODIFIED:20080416T075813
RECURRENCE-ID;TZID=/softwarestudio.org/Tzfile/Europe/Berlin:
 20080613T160000
ATTENDEE;CUTYPE=INDIVIDUAL;ROLE=REQ-PARTICIPANT;PARTSTAT=ACCEPTED;
 RSVP=TRUE;CN=Xxx Xxx;LANGUAGE=en:MAILTO:xxx@xxx.com
ATTENDEE;CUTYPE=INDIVIDUAL;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;
 RSVP=TRUE;CN=Yyy Yyy;LANGUAGE=en:MAILTO:yyy@yyy.biz
ATTENDEE;CUTYPE=INDIVIDUAL;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;
 RSVP=TRUE;CN=Zzz Zzz;LANGUAGE=en:MAILTO:
 zzz@zzz.biz
END:VEVENT
END:VCALENDAR


Reproducible: Didn't try

Steps to Reproduce:
1. Open the mail containing the respective invitation
Actual Results:  
The invitation is parsed and details are shown, but no Accept/Decline/Tentative buttons are visible.

Expected Results:  
Accept/Decline/Tentative buttons are visible.
(Assignee)

Comment 1

11 years ago
IMO duplocate to bug 392465.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> IMO duplocate to bug 392465.
> 

Surely not, I'd say, because I don't even see the Accept button, so I have no chance to click it...
(Assignee)

Comment 3

11 years ago
but I suspect the same core problem
Status: UNCONFIRMED → NEW
Depends on: 392465
Ever confirmed: true
Flags: wanted-calendar0.9+
I think the invitation bar issue can't be reproduced with just the iCalendar data. Could you export the entire email message and attach it here?
(Reporter)

Comment 5

11 years ago
Created attachment 324413 [details]
The mail containing the invitation
(Reporter)

Comment 6

11 years ago
Sure, see the attachment.

Updated

11 years ago
Flags: blocking-calendar0.9?

Updated

10 years ago
Whiteboard: [needs patch]
(Assignee)

Comment 7

10 years ago
Not going to happen for 0.9.
Flags: blocking-calendar0.9? → blocking-calendar0.9-
Whiteboard: [needs patch]
Duplicate of this bug: 451542
(Assignee)

Updated

10 years ago
Flags: wanted-calendar1.0+
Flags: wanted-calendar0.9+
Flags: blocking-calendar0.9-
(Assignee)

Comment 9

10 years ago
should be fixed with checkins of bug 392465
Assignee: nobody → daniel.boelzle
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0

Comment 10

9 years ago
Confirm that I am getting this exact bug with Thunderbird 0.9.  No meeting accept/decline invitations and the following errors in the console

Error: [Exception... "'Component not initialized' when calling method: [calIItipItem::getItemList]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: chrome://lightning/content/imip-bar.js :: processRequestMsg :: line 619"  data: no]
Source File: chrome://lightning/content/imip-bar.js
Line: 619

Comment 11

9 years ago
Running on 64 bit linux platform (Ubuntu 9.10)
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.