If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

packager.mk does not mount image automatically

RESOLVED FIXED

Status

()

Toolkit
Build Config
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: armenzg, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: hg patch missing, URL)

Attachments

(2 attachments, 3 obsolete attachments)

(Assignee)

Description

9 years ago
When I run "make installers-foo" from browser/locales I reach the line:
  echo Y | hdiutil attach -readonly -mountroot /tmp -private -noautoopen $(UNPACKAGE) > hdi.output;
which used to work to answer YES when questioned if we wanted to mount an image, BUT it doesn't not for me at least in Leopard (Axel says that he has the same problem on Tiger)
(Assignee)

Comment 1

9 years ago
Created attachment 324367 [details] [diff] [review]
installdmg.ex - Expect script that mounts a .dmg image

Putting it into toolokit/mozapps/installer might not be the best place to do so but will do for now
(Assignee)

Comment 2

9 years ago
Created attachment 324372 [details] [diff] [review]
packager.mk - it calls installerdmg.ex and fixes proper regex matching

These couple of patches should not work right away since it worked for me by placing installdmg.ex in my home folder and I was calling it in packager.mk by ~/installercmg.ex
I believe it didn't not work when I had it on toolkit/mozapps/installer, maybe something like $(PWD)/installdmg.ex might work

----------------
The regex matching now matches this:
MOUNTPOINT=/tmp/Minefield
instead of
MOUNTPOINT=$'/tmp/Minefield\r'

----------------
Axel and Alice had to create their own scripts to be able to work around this confirmed bug.

Comment 3

9 years ago
You probably want $(srcdir)/installdmg.ex
(Assignee)

Comment 4

9 years ago
I have seen hdi.output being generated under:
$(srcdir)/dist/l10n-stage

I will try both places - I will ask you for review when I have it working and I also tested it in previous versions of Mac OS X
(Assignee)

Comment 5

9 years ago
Created attachment 327687 [details] [diff] [review]
packager.mk + installerdmg.ex
Attachment #324367 - Attachment is obsolete: true
Attachment #324372 - Attachment is obsolete: true
(Assignee)

Comment 6

9 years ago
Created attachment 327827 [details] [diff] [review]
packager.mk + installerdmg.ex - It allows mounting on 10.5.x

I have finally tested it, I will attach script to see it working
Attachment #327687 - Attachment is obsolete: true
Attachment #327827 - Flags: review?(benjamin)
(Assignee)

Comment 7

9 years ago
Created attachment 327828 [details]
CreateLocalePackage - This script should not stop because of the mouting problem

This script will not work right away when tonight we get the 3.0.2 en-US build on latest-mozilla1.9.0.
You will have to modify the DMG_FILE and comment out the MOZ_CO_DATE
(Assignee)

Updated

9 years ago
Attachment #327828 - Attachment is patch: false
Attachment #327828 - Attachment mime type: text/plain → application/octet-stream

Comment 8

9 years ago
Comment on attachment 327827 [details] [diff] [review]
packager.mk + installerdmg.ex - It allows mounting on 10.5.x

boy, I'd be so much happier if the entire packaging system were python. In the meantime, r=me (I presume we can rely on the presence of expect on mac systems...?)
Attachment #327827 - Flags: review?(benjamin) → review+
(Assignee)

Comment 9

9 years ago
(In reply to comment #8)
> (I presume we can rely on the presence of expect on mac
> systems...?)
> 
In my mac came by default and alice has been using expect scripts for her talos machines

Benjamin, does this patch require more reviews?
Assignee: nobody → armenzg
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Whiteboard: hg patch missing
(Assignee)

Comment 10

9 years ago
http://tinderbox.mozilla.org/showbuilds.cgi?tree=MozillaTry&maxdate=1218135177&legend=0&norules=1

I have used the try server but it won't be relevant since that part of the code is not used at all. I think it is used only for L10n repackages

I will add the hg patch sometime between today and tomorrow

Comment 11

9 years ago
Pushed to mozilla-central, http://hg.mozilla.org/mozilla-central/index.cgi/rev/1c8dfe90f151
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.