Display name in Abook card does not automatically get entered.

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: esther, Assigned: chuang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using builds 2000-06-23 and tested again with 6/26 builds the Display Name in an 
Address Book card does not auto-populate when typing in the First Name and Last 
Name as it did in 4.5 - 4.7x.  Not specifically stated in spec that it should or 
shouldn't.

1. Launch Messenger
2. Launch Address Book
3. Select an Address Book in the left pane
4. Select New Card (either the toolbar button or from the menu list).
5. Enter a name in the First Name field, tab to the Last Name field and enter 
the last name.

Result: the First name and Last name are not shown in the Display Name field.  
Expected: Per 4.5x - 4.7x behavior the Display name should automatically get 
entered when typing in the First Name and Last Name of a new card.

If this is not going to be the behavior of 6.0, jennifer please update spec and 
mark this invalid.  If this should be the behavior, jennifer please update the 
spec and reassign to candice.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → esther

Comment 1

18 years ago
Yes, this should work the same as 4.x.  As the user type the First and Last 
name, the Display Name should be entered (First Last).  I will update the spec. 
 (I think this used to work in older seamonkey builds?)
Assignee: jglick → chuang

Comment 2

18 years ago
this is a dup of another non-mailnews bug about problems with text input fields.  
Have to look it up.

Comment 3

18 years ago
this is a dup of 42045 which has been fixed and I just verified that this is
working for me again in the ab card.

*** This bug has been marked as a duplicate of 42045 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
I'm reopening this bug. It works fine on WinNT and on Mac.

Linux only: If I type in first name and _tab_ to lastname and fill the last
name, the lastname is not automatically filled in the Display field (firstname
is filled in the display field).  But if I use the mouse and click on lastname,
it works fine.

Builds used: Today's commercial build on all platforms.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
Good catch, Suresh.

Comment 6

18 years ago
moving to M18.
Target Milestone: --- → M18

Comment 7

18 years ago
Nominating for nsbeta3 under "Correctness." App should perform as expected.
Keywords: correctness, nsbeta3
(Assignee)

Comment 8

18 years ago
Could this be xp bug since only Linux is broken?
(Assignee)

Comment 9

18 years ago
Created attachment 11720 [details] [diff] [review]
Patch for better visual feedback when dragover.(diff for messengerdnd.js)
(Assignee)

Comment 10

18 years ago
ignore the attachment, it should be for bug 40695.

Comment 11

18 years ago
Update: Display Name is NOT automatically get entered using today's build on 
Linux and Windows (both ways, by using tab and by using Mouse). It was working 
late last week.  

(Will update after Mac builds are out).

Comment 12

18 years ago
It's doesn't work on today's Mac build also.

Updated

18 years ago
Depends on: 46152

Comment 13

18 years ago
we should just mark as a duplicate of 46512
Now that bug 46152 is fixed, this one is gone too.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

18 years ago
Using build 2000-08-25 on win98, mac and linux this is fixed.  Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.