Firefox crash when using the HTTPS Settings of the igoogle Sidebar Extension [@ nsDocShell.cpp:7615]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({crash})

1.9.0 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 324527 [details]
crash stack

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008061017 Firefox/3.0pre

Steps to reproduce:
-> Install the igoogle Sidebar Extension
-> In the Extension Prefs select "Use Secure Connection HTTPS"
-> Restart Firefox
-> Go to the Extension Prefs again and uncheck"Use Secure Connection HTTPS" (you might repeat this step)
--> Firefox crash - Reproduced on Windows and Mac 10.5.3

Before you crash you see in the Debug Build Output:

###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file ../../dist/include/xpcom/nsCOMPtr.h, line 868

and later Firefox exists with:
./run-mozilla.sh: line 131:  1007 Bus error               "$prog" ${1+"$@"}
(Reporter)

Comment 1

11 years ago
Created attachment 324528 [details]
assertion stack from a windows debug build before the crash
(Reporter)

Updated

11 years ago
Component: General → Embedding: Docshell
QA Contact: general → docshell
Since you have this in a debugger... is mPrefs null?  Can you find out when it becomes null?  Does the extension have a binary blob?
Any chance of an answer to any of the questions in comment 2?
(Reporter)

Comment 4

10 years ago
Closing as worksforme because i can currently not reproduce this crash with a latest 1.9.0 build and the latest Extension Version, but i will do more tests on the weekend
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsDocShell.cpp:7615]
You need to log in before you can comment on or make changes to this bug.