All users were logged out of Bugzilla on October 13th, 2018

Dagesh and niqqud in wrong places (Hebrew script)

RESOLVED DUPLICATE of bug 60546

Status

()

RESOLVED DUPLICATE of bug 60546
11 years ago
11 years ago

People

(Reporter: igtorque, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

I have began to study Hebrew scripture, and I've found that relevant pages in the English (and Spanish) versions of Wikipedia renders diacritical marks (dagesh and niqqud, for instance) in the wrong places. For instance, the dagesh in letter Bet is always placed on the left side of the letter, instead of on the center ("inside" the letter).

However, the same pages viewed on the same PC, but with MSIE 7, renders them correctly.

The same happens with other sites, not just Firefox.



Reproducible: Always

Steps to Reproduce:
1. Go to http://en.wikipedia.org/wiki/Dagesh with Firefox
2. Go to http://en.wikipedia.org/wiki/Dagesh with MSIE 7
3. Compare the tables, or even the first sentence: The dagesh (דָּגֵשׁ) is a diacritic used ...
Actual Results:  
Diacritics in wrong places (always beside letters)

Expected Results:  
Diacritics in right places (above, below, inside or beside letters)

Locale: es_ES
This seems to work for me; can you retest with the latest trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.9.0/
Sorry, not trunk build but it is branch now (just the name). The link is correct.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

WFM on 2.0.0.14 and 3.0 nikud shows up as בּ correctly.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 60546
You need to log in before you can comment on or make changes to this bug.