Introduce "Meeting" category

VERIFIED FIXED in 1.0b1

Status

--
enhancement
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: victor.engmark, Assigned: aryx)

Tracking

Trunk
1.0b1

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080331 Sunbird/0.8

I'm surprised that the "Meeting" category for events & tasks has been removed - I don't know about other users, but for me it's by far the most important one.

PS: It's still mentioned in the Calendar FAQ in the Mozilla Wiki.

Reproducible: Always

Comment 1

10 years ago
options-categories -> you can (re)create it there... 
(Reporter)

Comment 2

10 years ago
I know. It's just a request, since I expect very few users know how or bother to do this, and I expect a significant fraction have gotten used to using that category by now.
Seems quite simple to me, although I don't think that users that don't bother with creating categories really care about the exact name of the category. We have a Business category, which I believe works equally well for those.

I think we have a bug or two about making it easier to create categories.

Christian, what do you think?
Whiteboard: [good first bug]
There never was a "Meeting" category, at least using Sunbird 0.2 or newer. 

In the FAQ I can't find a reference that a "Meeting" category existed except the section about how to assign a color via userChrome.css. In that section only non-existent categories are mentioned. By the way, the FAQ is out of date in may points.

You could morph this bug into an enhancement request to add it to the default category set. But this means a lot of work, in particular to update all localizations.

Comment 5

10 years ago
A default "Meeting" Category would be ok for me. It makes IMO totally sense.
Severity: trivial → enhancement
Status: UNCONFIRMED → NEW
Component: Tasks → Preferences
Ever confirmed: true
OS: Windows XP → All
QA Contact: tasks → preferences
Hardware: PC → All
Summary: Re-introduce "Meeting" category → Introduce "Meeting" category
Created attachment 334160 [details] [diff] [review]
meeting patch, v1

Ok, this is for post-0.9 and adds the meeting category. The entity "categories" has to be changed to "categories2" to indicate the l10n change.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #334160 - Flags: review?(philipp)
Whiteboard: [good first bug] → [post-0.9]

Comment 8

10 years ago
Wouldn't it just be enough to add the "meeting"-category to the list? I don't see the use of using categories2 apart from testing with an already defined list in a profile?
Existing strings shouldn't be changed without changing the entity name, because otherwise translators could miss the change.
Comment on attachment 334160 [details] [diff] [review]
meeting patch, v1

r=philipp
Attachment #334160 - Flags: review?(philipp) → review+
This patch needs checkin after 0.9, since it contains a string change.
Keywords: checkin-needed
Whiteboard: [post-0.9] → [checkin-needed after 0.9]
'checkin-needed': re-add this keyword when this can actually be done.
Keywords: checkin-needed
Version: unspecified → Trunk
Keywords: checkin-needed
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/9fdc552b6f7b>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin-needed after 0.9]
Target Milestone: --- → 1.0

Comment 14

10 years ago
checked in lightning build 20081015052201 and sunbird 20081015 -> VERIFIED
Status: RESOLVED → VERIFIED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.