OS/2 fontconfig cache does not update

RESOLVED DUPLICATE of bug 439193

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 439193
10 years ago
10 years ago

People

(Reporter: Steve Wendt, Unassigned)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Currently, if you install new fonts or remove some fonts, the FontConfig cache does not get updated to match, so weird font-matching could result.

The workaround is to delete the PM_Fonts_FontConfig_Cache_v1.1 key, so that it gets regenerated.  It would be nice if the cache could be dynamically updated:

1) remove entries for fonts which are no longer found
2) add entries for newly discovered fonts

I don't expect that the first part is very hard, but the "newly discovered" part is probably tricky...

Comment 1

10 years ago
At the very least deleting this key should be documented somewhere as the first step to trouble shooting font problems.

Comment 2

10 years ago
If you can write a paragraph for README.txt I will include it as documentation in the Firefox 3.0 GA. But we are too late to change the README in CVS, so not sure what we can otherwise do.

Would be better to fix the problem in the FontConfig port, though, in which case this would be invalid again.
(Reporter)

Comment 3

10 years ago
See attachment 325222 [details]; I don't know if you want to reference Bugzilla bugs?
(Reporter)

Comment 4

10 years ago
Hmmm... maybe "clear" the key isn't as clear as "delete" the key.  Feel free to change that word (or any others) for clarity.

Comment 5

10 years ago
OK, thanks. So the documentation part gets done in bug 439193, the rest is invalid as this again is a FC problem.
-> dupe
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439193
(Reporter)

Comment 6

10 years ago
If I understand this correctly:
https://bugzilla.mozilla.org/show_bug.cgi?id=439193#c6

this is fixed in mzfntcfgft_20080617.
You need to log in before you can comment on or make changes to this bug.