Applications preference list empty when gnome libraries are not installed

RESOLVED DUPLICATE of bug 409192

Status

()

RESOLVED DUPLICATE of bug 409192
11 years ago
11 years ago

People

(Reporter: glandium, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 325191 [details] [diff] [review]
patch

When the gnome libraries are not installed on the user system, the shell service module can't be loaded, which means all the code that is #ifdef'ed on HAVE_SHELL_SERVICE is likely to fail.
This makes the applications preference pane initialization code fail, because it gets an exception when intializating gApplicationPane members.
The attached patch solves the issue by using getShellService() defined in utilityOverlay.js, which fails gracefully.

It could be worth checking all places where HAVE_SHELL_SERVICE is ifdef'ed to see if runtime failure handling is required.
Attachment #325191 - Flags: review?(gavin.sharp)
Comment on attachment 325191 [details] [diff] [review]
patch

Can you update the comments in the try/catches that surround the uses of this property to also mention that shellSvc is potentially null?
Attachment #325191 - Flags: review?(gavin.sharp)
Please post the updated patch in bug 409192.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409192
You need to log in before you can comment on or make changes to this bug.