Table body background color extending beyond bottom of table

RESOLVED DUPLICATE of bug 423823

Status

()

--
major
RESOLVED DUPLICATE of bug 423823
11 years ago
11 years ago

People

(Reporter: duperon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-0etch1)
Build Identifier: Mozilla/5.0(Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

As the title says, the background color of table body cells extends past the end of the bottom of the table in FF3.  It's a strange bug that did not exist in previous versions of Firefox.  It really makes it impossible to see anything that exists below this table on the page.



Reproducible: Always

Steps to Reproduce:
Look at this code with FF3:

<html><head><title>Scrolling Table Bug</title>
<body>
    <div>
        <table border=0 width=565px cellspacing=0>
            <thead>
                <tr>
                    <td colspan=6 align=center >
                        <div>History</div>
                    </td>
                </tr>
                <!-- the column headers: -->
                <tr>
                    <th align="center"> Event Type </th>
                    <th align="center"> Date </th>
                    <th align="center"> Description </th>
                    <th align="center"> Thingy1 </th>
                    <th align="center"> Thingy2 </th>
                    <th width=15px >&nbsp;</th>
                </tr>
            </thead>
            <!-- <tbody style="overflow:-moz-scrollbars-vertical; height:180px;"> -->
            <tbody style="overflow-x:hidden;overflow-y:scroll; height:180px;">
                <tr  bgcolor="#dddddd">
                    <td> Inventory move </td>
                    <td > 04/02/2008 16:58 </td>
                    <td > Status set back to normal by Bob </td>
                    <td >&nbsp</td>
                    <td > &nbsp </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Inventory move </td>
                    <td > 04/02/2008 16:58 </td>
                    <td > Status set to remove by Bob</td>
                    <td > &nbsp </td>
                    <td > &nbsp </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Purchase order </td>
                    <td > 04/02/2008 16:49 </td>
                    <td > Completed transaction </td>
                    <td > &nbsp </td>
                    <td > &nbsp </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Purchase order </td>
                    <td > 04/02/2008 16:49 </td>
                    <td > New order </td>
                    <td > &nbsp </td>
                    <td > &nbsp </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                   <td > Rename </td>
                    <td > 30/01/2008 14:53 </td>
                    <td > Out of stores </td>
                    <td > &nbsp </td>
                    <td > &nbsp </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Change Owner </td>
                    <td > 22/01/2008 15:01 </td>
                    <td > Changed number of package by Tim. </td>
                    <td > &nbsp </td>
                    <td > &nbsp </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Move </td>
                    <td > 18/07/2007 10:55 </td>
                    <td > Moved by Fred. </td>
                    <td > B31-00276 </td>
                    <td > S31-01078 </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Move </td>
                    <td > 16/07/2007 14:03 </td>
                    <td > Moved by bob. </td>
                    <td > S31-01022 </td>
                    <td > B31-00276 </td>
                    <td width=5px >&nbsp;</td>
                </tr>
                <tr  bgcolor="#dddddd">
                    <td > Import </td>
                    <td > 12/07/2007 14:54 </td>
                    <td > Inventory added.  Additional comments:  </td>
                    <td > &nbsp </td>
                    <td > S31-01022 </td>
                    <td width=5px >&nbsp;</td>
                </tr>
            </tbody>
        </table>
    </div>
</body>
</html>





I was not using any special themes or doing anything special at all other than simply looking at a web page.  This is a pretty serious but that I'm surprised isn't already in the system (at least I didn't find it).  It only happens in Firefox 3.0.  It works fine in Firefox 2.0.
(Reporter)

Updated

11 years ago
Version: unspecified → 3.0 Branch

Comment 2

11 years ago
I think so too.  Bug 317137 says overflow auto and this is overflow scroll.  But they both occur when scrolling is needed by the tbody.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: 3.0 Branch → unspecified
(Reporter)

Comment 3

11 years ago
Looking at these other bugs, you are correct, they seem to be the same.  Sorry I didn't find them when first looking.  Maybe you guys can put some tips for finding bugs on the main web page?  I tried really hard to not repeat this one and failed :(.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 317137

Comment 5

11 years ago
Created attachment 326480 [details]
testcase from comment #0

Comment 6

11 years ago
Fixing incorrect dupe.
Duplicate of bug: 423823
You need to log in before you can comment on or make changes to this bug.