Firefox 3.0 blocks keyboard input to VMWare Fusion 1.1.1 Virtual Machines

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Tim Wood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Firefox 3.0.0 (released today 6/17/2008

There is a conflict between Firefox 3.0.0 and VMWare Fusion.  When both are running, virtual machines do not receive keyboard input.  Other running programs do receive keyboard input.

Replicated:
* with VMs running Windows XP and CentOS 5.x
* across reboots

Not Replicated:
* with Firefox 2.0.0.14

Versions:
* VMWare Fusion 1.1.1
* Mac OS X 10.5.3

Reported to VMWare (fusion-feedback@vmware.com) and Mozilla (bugzilla.mozilla.org)

Reproducible: Always

Steps to Reproduce:
1. Start VMWare Fusion
2. Open a virtual machines running WinXP or CentOS
3. Start Firefox 3.0
4. Try to type in any open virtual machine
Actual Results:  
No keyboard input is received.  Sometimes the computer beeps.

Expected Results:  
letters appear in the vm

VMWare Fusion is mission critical.  Had to revert to Firefox 2.0.0.14.
I won't be able to test this until (probably) next week.

Ben, are any of the server machines running VMware Fusion (they'd be OS X boxes, since VMware Fusion is the OS X equivalent of VMware Workstation).  If so, would it be possible to test this report on one of those machines (or any other such machine you're aware of and have access to)?

Feel free to CC others who might know more about this.
We do not run Fusion on the server-side at all. I run it on my personal laptop without problems. I'll try these specific STR in a bit, but I've never seen this before.
I can't reproduce this with the steps above
Thanks, Ben!

Your results suggest a couple of possibilities -- 1) that the STR from
comment #0 isn't detailed or precise enough, and/or 2) that some other
software may also be involved.
One more thing:

The current version of VMware Fusion is 1.1.3.
(Reporter)

Comment 6

10 years ago
Based on Steven's comments, I downloaded and installed 1.1.3 and the problem has disappeared.
> Based on Steven's comments, I downloaded and installed 1.1.3 and the
> problem has disappeared.

Thanks for letting us know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.