Location bar in Firefox 3 has an artifact when ClearType is turned on

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
trivial
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: manhinlinz, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

When XP's font smoothing system, ClearType, is activated and a new blank tab is open in Firefox 3, a orange artifact appears just a pixel to the left of the active cursor.

Reproducible: Sometimes

Steps to Reproduce:
1. Open a new tab, ensuring that the cursor is in the Location Bar.

Actual Results:  
There usually is an orange line right next to the blinking cursor.

Expected Results:  
There shouldn't be such an artifact.

Comment 1

10 years ago
works for me, but it's probably very dependent on your resolution and video card.
(Reporter)

Comment 2

10 years ago
Created attachment 325696 [details]
Image of artifact

Here is the image of the artifact. I'm not entirely sure if it's due to my video card and/or resolution of my monitor (1280x800 is a very common resolution)

Comment 3

10 years ago
I see this too when I'm using Tahoma; it's just never bothered me enough for me to file a bug about it.

Related: bug 430558
Status: UNCONFIRMED → NEW
Component: Location Bar and Autocomplete → GFX: Thebes
Ever confirmed: true
Product: Firefox → Core
QA Contact: location.bar → thebes
Version: unspecified → Trunk

Updated

10 years ago
Duplicate of this bug: 441269

Comment 5

10 years ago
I have 2 screenshots with this problem.

You can see on this screenshots only i small wrong char. But sometimes a char like a big i (I) is displayed.

starting posistion
http://www.hostpix.de/090110/kKkhW7Rw.png

navigation bar
http://www.hostpix.de/090110/98BSGz6H.png
Duplicate of this bug: 442979

Comment 7

10 years ago
Ive a new picture.

If you want to mark the whole URL, you can't do this.

http://www.hostpix.de/file.php?dat=6aOLyLNK.jpg

This bug is not only in search or loaction bar. I saw this artifact in a html-form element.

Updated

9 years ago
Duplicate of this bug: 452356

Updated

9 years ago
Duplicate of this bug: 430558
I can reproduce this on 3.0.19 on Windows XP in Windows Classic mode, with ClearType turned on. I think it's due to not invalidating the full extents of the fonts you've typed in the URL bar, possibly because ClearType draws them bigger than we think they are.

In any case, I *can't* reproduce this in latest Nightly on the same computer, so it seems that we have dealt with this problem sometime in the intervening while.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.