Weave (Firefox 3 Add-On) Login produces "Error", with no text in the log

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: talldean, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I installed the extension into a copy of Firefox 3.  I click login, type my login/pass/key combination, and click enter.  The icon on the bottom toolbar comes up red, with the text Error next to it.  I check the login information by logging into https://services.mozilla.com, and that works just fine.  I keep trying to log in, and still the same problem.  I look at the log, on the preferences screen, and both the regular and verbose logs are blank.

Putting this in as "critical", as "can't log into system" is a pretty big bug.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
I have exactly the same problem
(Reporter)

Comment 2

11 years ago
Still seeing this behavior.  Had heard rumor of a new release last Friday (6/20), and was waiting for that, but no new release, and still an Error on trying to connect to the server.

If there's any additional information I can add, or debugging steps I can try, please let me know.
(Reporter)

Comment 3

11 years ago
From CBeard, on the Mozilla Labs Forum today (6/24): The primary server cluster providing the back-end for the Weave experimental prototype will be mostly offline and largely unstable over the next 24 to 48 hours. We are migrating servers as well as preparing for the Weave 0.2 update. Thank you for your patience. More details soon.

From talldean@gmail.com: If this is still broken on 6/26, after the update, I'll update the bug.
(Reporter)

Comment 4

11 years ago
It's 6/26, the scheduled downtime is over, and this is still broken.  "Doesn't login at all, puts no errors into the log, and hasn't functioned for a week" is probably a critical bug, so bumping this up.
Severity: major → critical

Comment 5

11 years ago
i have the problem too. I can send logs if you need them
(Reporter)

Comment 6

11 years ago
Post up the logs; can't hurt.  The LDAP server looks to be back up, so I'm assuming things should function correctly now.

Comment 7

11 years ago
(In reply to comment #6)
> Post up the logs; can't hurt.  The LDAP server looks to be back up, so I'm
> assuming things should function correctly now.
> 

here they are: <a href="http://lifeisshit.foo.ru/files/foo/weave_sync.log">logs</a>
(Reporter)

Comment 8

11 years ago
Maybe take this one with $0.02, but my suggestion for Al would be

Go to Weave Preferences, click on Advanced, click "Reset Server Lock", try again, and report back?

Comment 9

11 years ago
(In reply to comment #8)
> Maybe take this one with $0.02, but my suggestion for Al would be
> 
> Go to Weave Preferences, click on Advanced, click "Reset Server Lock", try
> again, and report back?
> 

no, unluckily it doesn't work
I think it wouldn't work because until weave logins with my name it can not delete server lock (mutex?). I tryed to reset login but weave can't even verify my login. But on the http://services.mozilla.com site I login succesufully every time

Comment 10

11 years ago
maybe there is something blocking queries from russia? I mean blocking by IP

Comment 11

11 years ago
//or not only russia
(Reporter)

Comment 12

11 years ago
No idea.  I can try from home tonight, but the computer with the problem isn't mobile.

Comment 13

10 years ago
(In reply to comment #12)
> No idea.  I can try from home tonight, but the computer with the problem isn't
> mobile.
> 

excuse me, I didn't understand how CBeard had communicated with you?)
(Reporter)

Comment 14

10 years ago
CBeard hasn't gotten ahold of me in any way.

Comment 15

10 years ago
so that means that no one knows about the bug except us? ;) The status of the bug is unconfirmed still

Comment 16

10 years ago
I believe many of the login problems have been addressed with the 0.1.32 release, available on the weave forums as a developer snapshot.  Please try it and reopen this bug if necessary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---

Updated

10 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.