Tabs steal focus when they ask how/if to store cookies

RESOLVED DUPLICATE of bug 405239

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 405239
10 years ago
10 years ago

People

(Reporter: Athanasius, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0

If I am on tab X and navigate to a new URL, and that new URL includes cookie(s) that do match any of my cookie storage preferences yet, then when the popup is generated to ask me if I want to Allow/Allow for Session/Block the cookie, and I've switched to another tab before it got to that stage, I am suddenly back on the original tab.

Or to sum up: a tab asking about cookie preferences steals focus away from the current tab.

I have Tabs > "When I open a link in a new tab, switch to it immediately" disabled, although of course this has nothing to do with a new tab anyway.

I have no addon that changes the way tabs work.

Reproducible: Always

Steps to Reproduce:
1. Open tab X, navigate to a page, preferably one you know has some links that take a while to load.  It must also be a link that will cause a 'new' cookie to be offered that you've not yet set preferences for.
2. Open tab Y to another page
3. Now switch back to tab X, and hit one of those links.
4. Quickly switch to tab Y
5. Watch as you end up back on tab X for the cookie dialogue, and don't end up back on tab Y after answering it either.
Actual Results:  
Ended up away from the tab I was trying to use.

Expected Results:  
Tab 'focus' should stay on the tab I'm on unless *I* select another tab explicitly.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405239
You need to log in before you can comment on or make changes to this bug.