Font "Garamond" is displayed as bold but only in Windows

RESOLVED INCOMPLETE

Status

()

defect
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: adelyn.xx, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

URL describes it all, with screen caps included.
Pasting part of it:

I’ve been using Firefox 3 for quite some time on my macbook, and everything was working smoothly. Installed FF3 for PC this morning.

Immediately I was sorely disappointed by the font display and the great inconsistency between it and the mac version of FF3. Heart-strutter.org looks absolutely horrifying in FF3 (on Windows) as the font Garamond looks bold and ugly. I have ClearType off in Vista. Turning it on just made it look slightly less bold, but it still looks bold nonetheless.

Reproducible: Always

Steps to Reproduce:
1. Open browser.
2. Text looks awful.
Actual Results:  
Garamond looks bold when it shouldn't, maybe because it's set to a small size?

Expected Results:  
Garamond to look the way it does in the Opera 9.5 screen cap or at least the way it looks in FF2 or FF3 in Mac OS.

Comment 1

11 years ago
I don't see this problem on Windows.

This looks a lot like bug 428087, which was the result of a corruption of Windows font settings in the registry.  Uninstalling and reinstalling Garamond may help here.

I'm going to mark this as a dupe of bug 428087.  If you don't think that this is the same problem described in that bug, please re-open this bug.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428087

Comment 3

11 years ago
"This looks a lot like bug 428087, which was the result of a corruption of
Windows font settings in the registry.  Uninstalling and reinstalling Garamond
may help here."

If bug 428087 is a corruption of the Windows font settings then why does the bug not exist in the 032705 build but suddenly does exist in the 032805 build? Obviously the bug is a Firefox bug and not a Windows bug if a regression range can be found. Do the registry files in comments #5 and #7 of bug 428087 fix this bug for you?

Comment 4

11 years ago
(In reply to comment #3)
> If bug 428087 is a corruption of the Windows font settings then why does the
> bug not exist in the 032705 build but suddenly does exist in the 032805 build?
> Obviously the bug is a Firefox bug and not a Windows bug if a regression range
> can be found.
>
It's not clear where the problem lies, which is why 428087 is still open and hasn't been marked as INVALID.  I could reliably reproduce bug 428087 if I did some obviously wrong things to the Windows font registry.  At the same time, this bug does not occur in Fx2.  Fonts in Fx3 are handled very differently than fonts in Fx2 (we now use Thebes), and it's entirely possible that Fx2 handled this Windows error in a benign way and Fx3 does not--which is what I mean by it being unclear where exactly the problem is.

Also, I'm not sure if that regression range (2008032705-2008032805) is reliable, as there have been reports (either in the MZ thread or in one of the bugs; it's been a while since I last read these posts) of the bug happening prior to that range.

> Do the registry files in comments #5 and #7 of bug 428087 fix
> this bug for you?
> 
IIRC, those fixes were for a similar corruption to Arial, not Garamond, which is why I suggested uninstalling/reinstalling the font instead.
(Reporter)

Comment 5

11 years ago
Neither the fix or reinstalling the font seem to work and as far as I can tell everything is fine with other fonts. There is no missing string in Garamond in the registry, either. The font itself displays fine in IE, Flock, Opera.
Resolution: DUPLICATE → WONTFIX

Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Updated

11 years ago
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Not much activity here, and not clear that this isn't just a bug on one system. incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.