Last Comment Bug 440358 - no WCAP calendar events visible after restart of sunbird
: no WCAP calendar events visible after restart of sunbird
Status: VERIFIED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: WCAP (show other bugs)
: unspecified
: All All
: -- normal (vote)
: 0.9
Assigned To: Daniel Boelzle [:dbo]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 03:36 PDT by Andreas Treumann
Modified: 2008-08-10 23:21 PDT (History)
0 users
dbo.moz: blocking‑calendar0.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix - v1 (4.68 KB, patch)
2008-08-07 08:50 PDT, Daniel Boelzle [:dbo]
philipp: review+
Details | Diff | Splinter Review

Description Andreas Treumann 2008-06-19 03:36:33 PDT
STEPS TO REPRODUCE:
===================

- create a new sunbird profile
- add a WCAP calendar in sunbird
- restart sunbird
 
RESULT:
=======

- no WCAP calendar events visible
- only after a reload the events are visible

EXPECTED RESULT:
================

- the WCAP calendar events should be visible without a forced reload

REPRODUCIBLE:
=============

- always

Same scenario with a Webdav or caldav calendar needs no reload. If you use a WCAP and a Webdav/caldav calendar in parallel there is no reload necessary to get the WCAP events.

This is an 'sunbird only' issue.
Comment 1 Daniel Boelzle [:dbo] 2008-07-16 07:21:30 PDT
Hmm, reading the logs, the data is correctly provided.
Comment 2 Daniel Boelzle [:dbo] 2008-08-07 08:50:40 PDT
Created attachment 332737 [details] [diff] [review]
fix - v1
Comment 3 Daniel Boelzle [:dbo] 2008-08-07 08:52:28 PDT
Comment on attachment 332737 [details] [diff] [review]
fix - v1

It's actually a bug in wcap's initial session management uncovered by a startup race:
- initial refresh of views
- another refresh caused by setting offline state

The latter causes to cancel the pending login request which has cancelled all child requests.
Comment 4 Philipp Kewisch [:Fallen] 2008-08-08 09:37:25 PDT
Comment on attachment 332737 [details] [diff] [review]
fix - v1

In which cases is the calendar list not loaded?

It would be nice if we could enforce loading the tree, do you have an idea how this could happen? Otherwise, there are probably lots of places where we rely on DOM nodes being there, but I'd assume that if a chrome script is loaded, we should have access to the DOM. Obviously this happens before DOMContentLoaded, but it would be nice to find out if its possible to defer the call until the content is loaded.

r=philipp for now
Comment 5 Daniel Boelzle [:dbo] 2008-08-08 09:54:03 PDT
No idea yet, would be good to have a solution as our current code looks fragile w.r.t. that.

Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Comment 6 Andreas Treumann 2008-08-10 23:21:24 PDT
Checked with sunbird 20080811 -> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.