gentoo-Firefox crashes due to a bug in Sql Lite problem when writing in the location bar

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: gad, Assigned: armin76)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.9) Gecko/2008061912 (Gentoo) Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.9) Gecko/2008061912 (Gentoo) Firefox/3.0

Cannnot use the location bar to entry any URL

A crash will shut down the explorer with the following message:

firefox: sqlite3.c:37482: sqlite3VdbeMemFinalize: La declaración `0==(pMem->flags&0x0040) && !pMem->xDel' no se cumple.


This seems to be an assert.

I can reproduce 100% of time.

I tried to deinstall all extension but it's not related...

Reproducible: Always

Steps to Reproduce:
1.Write into the location bar
2.See firefox crashing.
You should not get this with the binary Mozilla.org build.
see also bug 439459
URL: Any
Component: Location Bar and Autocomplete → Storage
Product: Firefox → Toolkit
QA Contact: location.bar → storage
Version: unspecified → 1.9.0 Branch
can you get me two things please:

1) the Configure arguments information from about:buildconfig
2) the version of sqlite on your system

Updated

10 years ago
Assignee: nobody → armin76
Summary: Firefox crashes due to a bug in Sql Lite problem when writing in the location bar → gentoo-Firefox crashes due to a bug in Sql Lite problem when writing in the location bar

Comment 3

10 years ago
Same here, I have sqlite 3.5.9 

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
i686-pc-linux-gnu-gcc 	gcc version 4.1.2 (Gentoo 4.1.2) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -march=prescott -pipe -ggdb -Wno-return-type -w -fno-strict-aliasing -pthread -pipe
i686-pc-linux-gnu-g++ 	gcc version 4.1.2 (Gentoo 4.1.2) 	-fno-rtti -fno-handle-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -march=prescott -pipe -ggdb -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe -DGENTOO_NSPLUGINS_DIR=\"/usr/lib/nsplugins\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\"/usr/lib/nsbrowser/plugins\"

Configure arguments
--enable-application=xulrunner --enable-optimize=-O2 --disable-installer --disable-pedantic --enable-crypto --with-system-jpeg --with-system-zlib --disable-updater --enable-default-toolkit=gtk2 --enable-pango --enable-svg --enable-svg-renderer=cairo --enable-system-cairo --disable-strip --disable-strip-libs --disable-install-strip --enable-single-profile --disable-profilesharing --disable-profilelocking --enable-default-toolkit=cairo-gtk2 --enable-ipv6 --disable-startup-notification --disable-freetype2 --disable-debug --disable-tests --enable-reorder --enable-elf-dynstr-gc --disable-gnomevfs --disable-gnomeui --disable-mailnews --disable-mochitest --disable-crashreporter --enable-system-hunspell --enable-system-sqlite --enable-image-encoder=all --enable-canvas --enable-embedding-tests --with-system-nspr --with-system-nss --enable-system-lcms --with-system-bz2 --enable-oji --enable-mathml --enable-storage --enable-places --enable-places_bookmarks --enable-safe-browsing --enable-jsd --enable-xpctools --disable-libxul --with-default-mozilla-five-home=/usr/lib/xulrunner-1.9 --enable-extensions= --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu 
(Assignee)

Comment 4

10 years ago
We're now using in-source sqlite, just upgrade to xulrunner-1.9-r2 and mozilla-firefox-3.0-r1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(In reply to comment #4)
> We're now using in-source sqlite, just upgrade to xulrunner-1.9-r2 and
> mozilla-firefox-3.0-r1.
And I take it the issue went away?  I'm asking because we just upgraded to 3.5.9 in mozilla-central, and if we have a legit sqlite bug, we need to get it reported upstream.
You need to log in before you can comment on or make changes to this bug.