scrolling complex/big documents is slow and resource hungry

RESOLVED DUPLICATE of bug 428070

Status

()

Core
Widget: Cocoa
P3
normal
RESOLVED DUPLICATE of bug 428070
10 years ago
4 years ago

People

(Reporter: Till Backhaus, Assigned: smichaud)

Tracking

({perf, ue})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_3; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.20
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

scrolling through complex documents is slow and resource hungry.
The problem is independant from the input method and persists when scrolling using a) the scrollbar b) arrow keys c) the mouse-wheel.

under standard usage this shows up as a noticeable lag between input (moving the scrollwheel) and output (screen update) when one scrolls through the document.
to make the problem more visible one can scroll up and down several times in quick succession (10 times should be sufficient). firefox will really fall behind and the page can be seen moving for ~3 more seconds. During that time system load goes up and Firefox and WindowServer consume ~50% CPU each. (the cpu does not seem to be the bottleneck though since i'm on a multicore system and each core is used only half)
the problem does not seem to be new - i remember ff2 having the same problem although i did not check it again.

Reproducible: Always

Steps to Reproduce:
1. open http://www.djangoproject.com/documentation/db-api/ in firefox 3 on os x
2. scroll up and down a few times (just leave your finger on the mousewheel and move it up down) repeat 10 times

Actual Results:  
the document is scrolled up and down for ~3 more seconds

Expected Results:  
scrolling should be snappier, should not eat use so much resources

my system:
macbook 2.2ghz, 4gb ram, os x 10.5.3

Updated

10 years ago
Component: OS Integration → General
QA Contact: os.integration → general
Version: unspecified → 3.0 Branch
(Reporter)

Updated

10 years ago
Keywords: perf, ue
Whiteboard: DUPEME
I am able to reproduce this bug.

I have the following system:
Macbook pro 2.4GHz, 2 GB of RAM, OSX 10.5

According to anecdotal evidence from another mac user I know he did not have this problem in ff2, but he also experiences the issue in ff3. He has a black macbook.
(Assignee)

Comment 2

10 years ago
I see this too, in both FF3 and FF2, but (as far as I can tell) only
on Mac OS X (both 10.5.3 and 10.4.11).  So I'll classify this as a
Cocoa widgets bug.

There are some differences between OS X 10.4 and 10.5, and also
between FF2 and FF3.  But with this bug's URL
(http://www.djangoproject.com/documentation/db-api/) I see lagginess
in scrolling (particularly with the scrollbar and the arrow keys) that
I don't see in other browsers on OS X, or in FF2 or FF3 on Windows and
Linux.

I'm marking this P3 for two reasons:  On most sites you won't see the
problem, and it will probably be quite difficult to resolve.
Nonetheless, it _would_ be nice to be able to fix this (even though
I'll very likely have to do the fixing).
Assignee: nobody → joshmoz
Component: General → Widget: Cocoa
Product: Firefox → Core
QA Contact: general → cocoa
Version: 3.0 Branch → unspecified
(Assignee)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted1.9.1?
Priority: -- → P3
(Assignee)

Updated

10 years ago
Assignee: joshmoz → smichaud
(Assignee)

Comment 3

10 years ago
(Following up comment #2)

Camino (1.8-branch and trunk/1.9-branch) seems less laggy.  But I do
see noticeable lags on OS X 10.5.3 in trunk/1.9-branch Camino (using
today's nightly).

Most of my tests were done on an old MacBook Pro.  But I see lags even
on a very fast machine (a recent MacPro) in FF3 (and trunk Camino) on
OS X 10.5.3.

Since both FF3 and FF2 have this problem, this isn't strictly speaking
a Cocoa widgets bug.  But it's in Cocoa widgets code that the fix will
be landed (if we can find one).
(Assignee)

Comment 4

10 years ago
For the record I've mirrored this bug's URL
(http://www.djangoproject.com/documentation/db-api/), using wget
--mirror.  But the result (even bzipped) is probably too big (at just
over 10MB) to upload here.
Zapping overflow:auto in the stylesheet fixes this.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428070
Flags: wanted1.9.1?

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.