Last Comment Bug 440437 - If I visit a webpage with image maps, they don't work.
: If I visit a webpage with image maps, they don't work.
Status: RESOLVED INCOMPLETE
[CLOSEME 2010-10-01]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 3.0 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 08:24 PDT by kaal
Modified: 2010-10-03 18:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description kaal 2008-06-19 08:24:19 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

When I visit a webpage in firefox 3 containing image maps (e.g. <map id="example"><area ... /></map><img ... usemap="#example">) they just don't work, in the FF source code i've seen that ff WILL read it and understand it, but it don't make the hyperlinks, please make an update that make it happen it will work.

Reproducible: Always

Steps to Reproduce:
I don't know? Editing the source code of firefox?
Actual Results:  
-

Expected Results:  
-
Comment 1 Jo Hermans 2008-06-19 08:54:00 PDT
Can you give an example of such a site ?
Comment 2 Peter K. Hadley 2010-07-28 13:25:44 PDT
I notice in my own work that the map for a circle shows up but it is on the left side of the image, not where it belongs.  It seems that the y coordinate and the radius are done properly.  My guess is that somewhere you either drop or misspell the x-coordinate of the center.

An example is sometimes available at https://www.instigations.com/internals2/logos.php?cmd=showreloid  Because I'm still working on this (including a possibility of a workaround), this URI may or may not be available at any time.
Comment 3 Tyler Downer [:Tyler] 2010-09-12 22:09:06 PDT
Reporter, are you still seeing this issue with Firefox 3.6.9 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Comment 4 Peter K. Hadley 2010-09-13 09:09:17 PDT
It's the unsafe mode I'm worried about.  It still seems to find the link only on the left side of the image.  My link to a nonworking example is now off the air.  I have constructed a new one at
https://www.reloid.com/fulllogo.htm
Note that when the mouse goes over the foot, an alternate graphic should show up and it should revert when the mouse leaves the graphic.  IE does this.

Firefox will pop up the alternate graphic when the mouse is on the left side of the picture at the correct level but do nothing when the mouse is over the foot.
Comment 5 Tyler Downer [:Tyler] 2010-10-03 16:24:05 PDT
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Comment 6 Peter K. Hadley 2010-10-03 18:00:16 PDT
Why do you send me to a page which says not to use profiles unless I'm an extension developer?  Firefox 3.6.10 does not solve the problem and I don't even have an old profile.  The mouseover still pops up when my cursor is at the same y-level but when I'm all the way over to the left.

Note You need to log in before you can comment on or make changes to this bug.