Last Comment Bug 440486 - The FAX dialog disappear and Fax cannot be done from Firefox, but works otherwise
: The FAX dialog disappear and Fax cannot be done from Firefox, but works other...
Status: RESOLVED FIXED
[remove relnote?][needs 1.9.1 landing]
: regression, relnote
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Windows XP
: P2 major with 6 votes (vote)
: ---
Assigned To: Johnny Stenback (:jst, jst@mozilla.com)
:
:
Mentors:
: 442945 484651 (view as bug list)
Depends on:
Blocks: 352791
  Show dependency treegraph
 
Reported: 2008-06-19 11:20 PDT by Raj
Modified: 2014-10-11 15:14 PDT (History)
31 users (show)
benjamin: blocking1.9.2+
benjamin: blocking1.9.1-
benjamin: wanted1.9.1+
samuel.sidler+old: blocking1.9.1.1-
samuel.sidler+old: blocking1.9.0.2-
samuel.sidler+old: wanted1.9.0.x+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
alpha1+
beta2-fixed
.8-fixed


Attachments
Fix. (1.61 KB, patch)
2009-11-05 15:12 PST, Johnny Stenback (:jst, jst@mozilla.com)
robert.strong.bugs: review+
Details | Diff | Splinter Review
Fix that actually works on 1.9.1 (1.64 KB, patch)
2010-01-27 17:31 PST, Johnny Stenback (:jst, jst@mozilla.com)
no flags Details | Diff | Splinter Review
Fix that actually works on 1.9.1 (1.62 KB, patch)
2010-01-27 18:08 PST, Johnny Stenback (:jst, jst@mozilla.com)
dolske: review+
dveditz: approval1.9.1.8+
Details | Diff | Splinter Review

Description Raj 2008-06-19 11:20:55 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Hi,

On File, Print and selecting "Fax" the dialog box does not bring the fax information dialog box. Other applications including openOffice can do the fax. It started happening after upgrade to Firefox 3.0

Thanks
Raj


Reproducible: Always

Steps to Reproduce:
1.on any webpage go to File manu
2.Select Print
3.Select "fax" as Printer name
4. Click OK.

The same use to work in earlier release of Firefox and still works in other applications.
Actual Results:  
as above

Expected Results:  
The dialog box should bring the "Send Fax Wizard"
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2008-07-02 12:37:31 PDT
This regressed between 2008-01-14 and 2008-01-16. In the 2008-01-15 build it started crashing.

Bonsai link between 2008-01-14 and 2008-01-15:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-01-14+04&maxdate=2008-01-15+07&cvsroot=%2Fcvsroot

Bonsai link between 2008-01-15 and 2008-01-16:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-01-15+04&maxdate=2008-01-16+07&cvsroot=%2Fcvsroot

My best bet is that this is a regression from bug 352791, since that one has caused bug 413200, which seems related.
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2008-07-02 12:37:59 PDT
*** Bug 442945 has been marked as a duplicate of this bug. ***
Comment 3 Samuel Sidler (old account; do not CC) 2008-08-14 13:38:04 PDT
We won't block 1.9.0.2 on this, but it's definitely wanted and something we should take for 1.9.0.3.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2008-08-22 09:43:04 PDT
How do you expect it to get fixed if it's not assigned to anyone, exactly?  What will happen to get it assigned?
Comment 5 Samuel Sidler (old account; do not CC) 2008-08-22 11:16:39 PDT
Boris, I intended on circling back around to find an owner after code freeze for 1.9.0.2.
Comment 6 William 2008-09-16 23:04:33 PDT
If it helps as an additional data point, I ran into this problem recently on an older (slower) Pentium III computer running Fx 3.0 and Windows XP Pro SP3. After selecting the "fax" printer device in the printer properties dialog, the "send fax" wizard did in fact appear for a split second before disappearing.

I could find nothing in the system event log, and Firefox kept right on running.
Comment 7 Samuel Sidler (old account; do not CC) 2008-10-03 11:34:54 PDT
Johnny, can you look at this since you fixed bug 413200?
Comment 8 Damon Sicore (:damons) 2008-11-12 21:54:42 PST
Boris, why do you think this should block 1.9.1 at this point?
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2008-11-13 07:30:25 PST
Damon, I think we need to fix this regression.  Note that I made the blocking request in July...

It does seem unlikely that we'll block for 1.9.1 on this now that we're here and not in July, but I don't think we want to just lose track of this bug.  We have a regression range and such; we just need someone on Windows to sit down and take a look at what's happening.
Comment 10 wes 2009-03-09 07:19:36 PDT
I am having this same problem. Has there been any fix yet?
As soon as i choose my 'fax' from my list of printers, the fax dialog box appears for a split second, then disappears. This started happening to me right after i upgraded firefox.
Comment 11 Daniel Veditz [:dveditz] 2009-03-09 11:14:50 PDT
If it's not blocking1.9.1 we're not going to get the developer resources to be able to block1.9.0.x -- we'll look at a fix when it's fixed on trunk.
Comment 12 Ryan 2009-04-30 12:00:13 PDT
Any updates on this bug?

This is unfortunately delaying implementation of Firefox 3 in my environment.
Comment 13 wes 2009-05-01 05:15:27 PDT
Due to the long delay in any fix for this problem, I've decided to uninstall firefox and try google chrome.
Comment 14 Damon Sicore (:damons) 2009-05-01 11:11:09 PDT
Grrr.  Yeah, we really should fix this.  I'm going to find a dev to dig into this.
Comment 15 Andrew Hagen 2009-05-02 05:45:43 PDT
*** Bug 484651 has been marked as a duplicate of this bug. ***
Comment 16 Andrew Hagen 2009-05-02 05:50:38 PDT
We should have a release note so that people trying to use Firefox to fax from XP aren't confused. This one got me.
Comment 17 Matt Jeffers 2009-06-25 07:32:13 PDT
I'm seeing this same behaviour.
A workaround is to open the same URL in Internet Explorer ;)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.11)
Gecko/2009060215 Firefox/3.0.11
Comment 18 Nochum Sossonko [:Natch] 2009-07-01 14:28:09 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
fwiw, selecting fax works for me on the release 3.5 running Vista.
Comment 19 Ryan 2009-07-01 14:47:34 PDT
Faxing is working correctly with Firefox 3.5 on Windows XP

Looks like the bug was fixed for that release?
Comment 20 Johnny Stenback (:jst, jst@mozilla.com) 2009-07-01 14:54:57 PDT
Hmm, so either this was fixed by some other bug fix, or this problem is specific to a specific Fax driver or something else. Raj, can you test again and let us know what fax driver etc you're using, to maybe see if others with the same setup can reproduce as well?
Comment 21 Ryan 2009-07-01 15:36:13 PDT
I can test this again on multiple systems.

I will report working/not working with 3.0.x and 3.5

I'll try to uncover Shared Fax Driver versions as well.
Comment 22 Martijn Wargers [:mwargers] (not working for Mozilla) 2009-07-02 03:01:25 PDT
I can still see the bug in current trunk build.
Comment 23 Samuel Sidler (old account; do not CC) 2009-07-09 19:00:32 PDT
We won't block 1.9.1.1 on this but will consider a fix should one appear.
Comment 24 Mike Rothaus 2009-07-17 16:41:11 PDT
This bug is definitely also in the latest 3.5.1 release build.  I have Windows XP SP3 and am using the Microsoft Fax that comes with the operating system.

If I print to the fax, I can see the usual first form "Send a fax" appear briefly, it is totally empty, and then it disappears.
Comment 25 Ryan 2009-09-10 12:49:26 PDT
Any progress towards a fix for this issue?
Comment 26 Martijn Wargers [:mwargers] (not working for Mozilla) 2009-09-10 15:16:43 PDT
CC-ing some windows developers.
Comment 27 Ryan 2009-09-10 15:29:40 PDT
I did just discover a single system in my office that is not affected by the bug for some reason. Here is what I found.

Doesn't work
Firefox 3.5.2
Fax  SHRFAX: Driver ver.5.2.2600.5512 (xpsp.080413-0852)

Works
XP SP2
Firefox 3.0.12
Fax  SHRFAX: Driver ver.5.2.2600.2180 (xpsp_sp2_rtm.040803-2158)

Doesn't work after Firefox upgrade
XP SP2
Firefox 3.5 
Fax  SHRFAX: Driver ver.5.2.2600.2180 (xpsp_sp2_rtm.040803-2158)

After upgrading the working machine to Firefox 3.5 faxing ceased to function.
Comment 28 darkmagicianx5 2009-09-11 07:19:58 PDT
Hi,

I'm running Firefox 3.5.3

On XP SP3
Fax SHRFAX: Driver 5.2.2600.5512

The wizard comes up, but the first time after I set it up, it showed up underneath Firefox. Now, every subsequent invocation, have the dialog showing up fine.
Comment 29 Sraban 2009-09-14 05:25:12 PDT
Hi
A simple work around is to install IE tab plug in. The issue doesnt crop up then.
Comment 30 Ryan 2009-10-21 13:29:51 PDT
Any hope here?

I'm getting pressure to get a more advanced browser in house, and IE8 looks like it might be the only option.
Comment 31 Mike Rothaus 2009-10-21 20:35:25 PDT
I found a really good work-around.  I use the "Coral IE Tab" add-in.  It allows a Firefox tab to be rendered using the IE engine.  It can be set up so that you can click on the firefox icon at the bottom right, which turns the icon into an IE icon, and the page is rendered using the IE engine.  Then you can print using Microsoft Fax and it works perfectly.
Comment 32 Ryan 2009-10-22 09:03:18 PDT
I am aware of the IE Tab work-arounds. Unfortunately I support about 300 users, and the time and effort it would take to install the extension and educate them on what to do negates the benefit of using the work-around.

Thanks though
Comment 33 joe630 2009-10-27 10:37:49 PDT
I have another work around when you click with the mouse on the printing progress screen (small pop up) for about 3-4 seconds the fax dialog does appear and you can fax from Microsoft as usual.
Comment 34 Ryan 2009-10-27 11:27:53 PDT
I have confirmed that holding the Printing Progress screen does allow faxes to be sent.

Maybe this will help the devs figure out what is causing the issue.
Comment 35 Damon Sicore (:damons) 2009-10-28 11:03:06 PDT
Johnny, any progress here?
Comment 36 Johnny Stenback (:jst, jst@mozilla.com) 2009-11-04 21:04:27 PST
Yes! But no patch in sight yet. What I've learned here is that the fax dialog that appears after the progress dialog disappears appears to be parented at the progress dialog, and when we tear down the progress dialog, the fax dialog goes along with it, which is why it only flashes on the screen momentarily.

The suggested workaround makes the progress dialog stay around longer (since the mouse holds it alive), long enough that the fax dialog gets established enough to hold the progress dialog alive (yeah, I'm hand waving a bit here). Another workaround is to click in another window after the progress dialog is opened, but before the fax dialog is opened, doing that gives focus to whatever window you click in (can even be the desktop), and makes the fax dialog survive us tearing down the progress dialog here.

So it seems like this is due to an odd interaction between the currently focused window and the Windows XP fax dialog. I've been unable to reproduce this on Vista or Windows 7.

Jim Mathies, Rob Strong, or anyone else, if anything stands out as obvious to you guys as far as fixing this, please let me know :) I'll be digging in a bit deeper here tomorrow, but I don't immediately know how to get around this, short of figuring out a way to re-order things here so that the progress dialog goes away sooner to not be the currently active window when the fax dialog is brought up by Windows...
Comment 37 Boris Zbarsky [:bz] (still a bit busy) 2009-11-04 21:24:48 PST
Hmm.  I see nothing in the ranges from comment 1 that would be related to window parenting on Windows, offhand.  There are some widget/ changes, but they're gtk2 and cocoa.  And nothing obviously touching the relevant cross-platform code.

Martijn, can you confirm that regression range, just to double-check?
Comment 38 Blake Kaplan (:mrbkap) 2009-11-05 06:15:22 PST
(In reply to comment #37)
> Hmm.  I see nothing in the ranges from comment 1 that would be related to
> window parenting on Windows, offhand.  There are some widget/ changes, but
> they're gtk2 and cocoa.  And nothing obviously touching the relevant
> cross-platform code.

FWIW, my money's on bug 352791. In particular, if we have any code anywhere that uses the context stack, then bug 352791 could very well have caused us to run some code on a different context, which could very well cause us to use the context as the parent for something instead of whatever it was we did before.

jst, do you hit a breakpoint in GetContextFromObject just before the Fax dialog comes up?
Comment 39 Johnny Stenback (:jst, jst@mozilla.com) 2009-11-05 15:10:05 PST
So my bet is that this has to do with us running JS on a different context, which affects how windows are closed (sync vs not), which does explain why this worked before, but not after the fix for bug 352791, which changed exactly that.

I have a fix for this, and I'm convinced that this just happened to work before the fix for bug 352791 went in by pure accident. And ultimately, this is a bug in Windows XP's fax dialog, no question about that in my mind.
Comment 40 Johnny Stenback (:jst, jst@mozilla.com) 2009-11-05 15:12:10 PST
Created attachment 410638 [details] [diff] [review]
Fix.

See the big comment in the patch for explanation.
Comment 41 Ryan 2009-11-05 16:32:59 PST
Thanks for the hard work everyone.

Imagine that... A bug in a Windows UI element... :)
Comment 42 Johnny Stenback (:jst, jst@mozilla.com) 2009-11-05 21:15:47 PST
Fixed on trunk.

http://hg.mozilla.org/mozilla-central/rev/bcd91fc6969b
Comment 43 Johnny Stenback (:jst, jst@mozilla.com) 2009-11-06 15:14:46 PST
Fixed for 1.9.2.

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/f36f5199be3d
Comment 44 joe630 2009-11-10 08:26:17 PST
How do I install the fix
Comment 45 darkmagicianx5 2009-11-10 08:51:07 PST
Download the nightly build or wait till rv 1.9.2 is released. The current release 3.5.5 is rv 1.9.1.5.
Comment 46 Daniel Veditz [:dveditz] 2009-12-18 11:46:59 PST
Comment on attachment 410638 [details] [diff] [review]
Fix.

Approved for 1.9.1.8, a=dveditz for release-drivers
Comment 47 David Baron :dbaron: ⌚️UTC-8 2010-01-22 14:30:12 PST
Marking the 14 bugs that are both:
 * nominated for blocking1.9.3:?
 * fixed on the 1.9.2 branch (according to status1.9.2)
as blocking1.9.3:alpha1, so that we don't have to go through the nominations individually.  They're all fixed already (so there's no work to do), and being fixed on 1.9.2 means they probably do block 1.9.3.
Comment 48 Johnny Stenback (:jst, jst@mozilla.com) 2010-01-27 17:31:42 PST
Created attachment 423908 [details] [diff] [review]
Fix that actually works on 1.9.1

Turns out there's no focus manager on 1.9.1, so we'll need to use the window mediator there.
Comment 49 Johnny Stenback (:jst, jst@mozilla.com) 2010-01-27 18:08:35 PST
Created attachment 423913 [details] [diff] [review]
Fix that actually works on 1.9.1
Comment 50 Justin Dolske [:Dolske] 2010-01-27 18:10:59 PST
Comment on attachment 423913 [details] [diff] [review]
Fix that actually works on 1.9.1

r+, god help me for reviewing focus+printing code! :)
Comment 51 Daniel Veditz [:dveditz] 2010-01-27 18:13:44 PST
Comment on attachment 423913 [details] [diff] [review]
Fix that actually works on 1.9.1

approved for 1.9.1.8, a=dveditz
Comment 52 Johnny Stenback (:jst, jst@mozilla.com) 2010-01-27 18:23:05 PST
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/fc4888716a4b
Comment 53 Wayne Mery (:wsmwk, NI for questions) 2010-06-12 19:38:21 PDT
http://gsfn.us/t/pj59 states seeing this issue with thunderbird 3.0.2 thru 3.0.4, which have this fix
Comment 54 Boris Zbarsky [:bz] (still a bit busy) 2010-06-14 11:15:36 PDT
Wayne, if this now happens with tbird but not Firefox, we should file a separate bug to track that...  That will make sure it doesn't get lost.
Comment 55 Joshua Mitchell (Inactive) 2014-10-11 15:14:40 PDT
Issue is Resolved - removing QA-Wanted Keywords - QA-Wanted query clean-up task

Note You need to log in before you can comment on or make changes to this bug.