Center clicking on a non-link treats clipboard contents as a link in the current tab

VERIFIED DUPLICATE of bug 135884

Status

()

VERIFIED DUPLICATE of bug 135884
10 years ago
10 years ago

People

(Reporter: peng.thinkblue, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

Center clicking a link to open it in a new tab is a fantastic feature, but if you center click in Firefox 3 and don't have your mouse on a link the current tab is replaced with the result of clicking a link containing the contents of your clipboard.

Reproducible: Always

Steps to Reproduce:
1. Center click but don't have your mouse on top of a link (just off the link works as well as being completely away from any link
Actual Results:  
The tab's contents are replaced with a link consisting of the contents of your system clipboard

Expected Results:  
The link should have opened in a new tab, or at least a dialog should have popped up informing you that the selected link is in fact not a valid hyperlink

This has actually been an ongoing issue since early Firefox 3 betas and I've been meaning to report it. While annoying as hell it's not a major bug. I'm surprised it hasn't been reported yet, or at least I couldn't find a bug when I searched for it.
Mmm, a little tiny bit before Fx 3 betas: more like before 0.9, and I don't mean Firefox 0.9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 135884
(Reporter)

Comment 2

10 years ago
Damn, it's been that long? I know I used to get an error popup before. Perhaps I'm thinking back to when I was a Windows user, but I'm surprised it still exists after a couple of years.
In fact, this is not a bug. It's meant to be a feature. :)

verified duplicate.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

10 years ago
I'm sorry, but if it's a feature it's one of the most useless features implemented lately. Twice today I tried to middle click a link and missed by just enough to load a new page into the tab. Once was on a forum and I lost what I had typed in already due to how the page is coded.
You can turn this behaviour off by setting middlemouse.contentLoadURL to false. See http://kb.mozillazine.org/Middlemouse.contentLoadURL for details.
(Reporter)

Comment 6

10 years ago
I just saw that in the other bug, and have blogged it to let others know of the option.
You need to log in before you can comment on or make changes to this bug.