Unread status not marked read if read externally

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: jcranmer, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Admittedly, a bit of an edge case, but it's still a bug.

If I have two Thunderbird instances running, and both are pointed to the same IMAP folder (both using IDLE), and I mark read in one, it is not marked, after any delay, read in the other.

Steps to Reproduce:
0. Generate a large source of email, like a mass-QA change on bugzilla (not really necessary, but it helps).
1. Let a message appear in both instances.
2. In one instance, mark it as read. Delete another message.
3. Check the other instance. Note that the deleted message is correctly deleted, but that the read instance is not.
(Assignee)

Comment 1

9 years ago
a protocol log might be helpful - it's up to the server what state changes it communicates between open connections.

Comment 2

9 years ago
Joshua,

Just a couple of thoughts....

I use this feature extensively on Tbird 2.x.... have sometimes 5 instances pointing at the same server.... Did this work on Thunnderbird 2.x with two instances running talking to the same server you are using now with Shredder?

Also, it might help the developers to know what IMAP server/version/platform you are connecting to, if that is non-trivial to determine.
(Reporter)

Comment 3

9 years ago
This was (IIRC) TB 3.0 on one side and TB 2.0 on the other--I don't remember which one I marked the message as read (possibly 3.0, given the circumstances). This was gmail IMAP, so this is probably just a gmail-really-really-sucks-at-IMAP problem.
To Joshua Cranmer(bug opener):
Get IMAP log and check real IMAP level flow first, before suspecting gmail-really-really-sucks-at-IMAP with no evidence of that.
> http://kb.mozillazine.org/Session_logging_for_mail/news
> Link of "MailNews Logging" ( https://wiki.mozilla.org/MailNews:Logging )
> RFC 2060(IMAP4rev1) http://www.faqs.org/rfcs/rfc2060.html

AFAIK, there are some problems in reflecting of status which is changed by other client. For example, Bug 450246 is issue in "removed tag by other client" case. (When Gmail IMAP, Bug 450246 can occur even upon "removal of a tag by myself in other mail folder", because of Gmail IMAP's special design.)
Product: Core → MailNews Core
(Reporter)

Comment 5

9 years ago
Just tried this recently, and confirmed that it would mark the unread status as read after a while, so it WFM now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.