Closed Bug 440829 Opened 13 years ago Closed 13 years ago

Firefox 3 : BadGC with flash in non-current tab on Solaris

Categories

(Core :: Plug-ins, defect)

Sun
Solaris
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: km, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9) Gecko/2008061816 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9) Gecko/2008061816 Firefox/3.0

Under some circumstances if a flash enabled page renders in a non-current tab the browser will terminate with 

The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadGC (invalid GC parameter)'.

This occurs on Solaris both Sparc and X86 (Nevada build 90)

It occurs with the flashplugin 9.0 r124. It occurs with or without flashblocker, even if the flash content is blocked.

I'm attaching a sessionstore.js that will reproduce this. It does not occur on Firefox 2.x, and does not occur on Linux Firfox 3.0. Just Solaris Firefox 3.


Reproducible: Always

Steps to Reproduce:
1. Substitute the provided sessionstore.js in your profile directory.
2. Start firefox and wait for all tabs to complete loading
3.
Actual Results:  
browser crashes

Expected Results:  
not crash

Should you make the tab with the flash content current before it finishes rendering the error will not occur.
Not just a sun4u issue - happens on x64 too with the same signature.

Build identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9) Gecko/2008060510 Firefox/3.0

It is a bug of Flashplayer plugin 9.0 r124 of Solaris.

Flashplayer 9.0 r125 for Solaris is coming to resolve it.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Odd that it shows with flashblocker, isn't it?
I got it reproduce without flashblocker installed.

Ginn - do we have an ETA on 9.0 r125?
>I got it reproduce without flashblocker installed.

Yes, but isn't it odder that if the bug is in the flashplugin that it shows WITH flashblocker installed.

(In reply to comment #5)
> I got it reproduce without flashblocker installed.
> 
> Ginn - do we have an ETA on 9.0 r125?
> 

A week or so, I think.
Component: Tabbed Browser → Plug-ins
Product: Firefox → Core
QA Contact: tabbed.browser → plugins
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.