Please make image drag and drop support content-disposition

RESOLVED DUPLICATE of bug 291837

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 291837
10 years ago
9 years ago

People

(Reporter: Mark Harrison, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

given URL:
    http://example.com/imageviewer/DSC_7918/thumbnail
that has this directive:
    content-disposition: inline; filename=DSC_7918.jpg


File/Save will properly use the filename "DSC_7918.jpg".

Dragging the image to another application will incorrectly
use the filename "thumbnail.jpg".

Desired behavior: please make drag and drop use the filename
specified in content-disposition.

Thanks, and 3.0 is an awesome upgrade in every way... speed,
functionality, visuals... great job!

Reproducible: Always

Steps to Reproduce:
1. view an image file with content-disposition set
2. drag the image to the desktop

Actual Results:  
The file on the desktop does not use the content-disposition name, unlike the File/Save command

Expected Results:  
The file should be named as per content-disposition.
> http://example.com/imageviewer/DSC_7918/thumbnail

This URL doesn't work (it triggers a 404 Not Found error).

Please provide one that does.
(Reporter)

Comment 2

10 years ago
Unfortunately, the only server I'm using which are setting content-disposition are internal servers.  That's why I used example.com.

Thanks!
Mark

Updated

10 years ago
Blocks: 449588

Comment 3

9 years ago
dupe of bug 291837?
No longer blocks: 449588
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 291837
You need to log in before you can comment on or make changes to this bug.