Closed Bug 440963 Opened 11 years ago Closed 11 years ago

color profile whitish

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: epistemepromeneur, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.9 (like Gecko)
Build Identifier: Fiefox/3.0

i enabled the color profile management
with default sRGB color profil or my screen's color profile
my photos are whitish

Reproducible: Always

Steps to Reproduce:
1. go my panoramio web
2. view any snapshot
3. each of one is whitish
Looking at the "paysage" image, the snapshot is in JPEG format and is not tagged with any color profile info.
Blocks: 418538
(In reply to comment #1)
> Looking at the "paysage" image, the snapshot is in JPEG format and is not
> tagged with any color profile info.
> 

it is strange


the image is an original one from my DSC
i use the panoramio web tool to load the image to panoramio.
when i view the image with digikam there is a color profile
see the attachment digikam.png



Attached image see the color profile
see the color profile
Your color profile says it is "sRGB" using the D50 white point.  It is not actually sRGB, then, because sRGB specifies using D65.

I've been testing your image (downloaded via FF-3.0) with ImageMagick's "identify -verbose" and with GraphicsMagick's "gm identify -verbose", and neither gives any indication of the presence of a color profile.

Please attach a copy of the original image039.jpg from your DSC.
i can't attach a 1.3 Mo file
Attached image img027.jpg
a picture of the same group (same dsc)
the img027.jpg is at

http://picasaweb.google.fr/pcspromeneur/SeineEtMarne

in my picasaweb there are only original pictures. I did not reduce them or change them
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
i made some experiments today:

- with default color profile : no pb
- with my screen color profile : whitish

i assume that color profiles supplied by Philips are bad
If this is converging on a resolution that color-shifting is due to a bogus screen profile, then this would be a dupe of bug #440940.  Is your default color profile using a D65 white point?
(In reply to comment #9)
> If this is converging on a resolution that color-shifting is due to a bogus
> screen profile, then this would be a dupe of bug #440940.  Is your default
> color profile using a D65 white point?
> 
i don't know

see the attachment
Attached file PhLCD17a.icm
color profile of my Philips 170C5 lcd monitor
promeneur - I'm guessing your profile is screwed up. On my display, it has similar behavior to bug 440940, which I just closed as invalid. Moreover, images are looking rather washed out, which sounds like what you're seeing. However, since I don't have the Philips display the profile is supposedly calibrated for, it's hard for me to tell.

Do you have a recent version of photoshop? If so, could you try loading the image there and see if the same color issues crop up?
(In reply to comment #12)

as i said in my description i use linux mandriva 2008.1 with digikam
i don't use MS windows with Photoshop.

if i use the philips profile with digikam the images are withish.
if i use sRGB profile as my screen profile with digikam the images are good.

note : sRGB is the default profile in the Philips display firmware

promeneur - Sorry about the photoshop thing - forgot you were using linux.

Looks like the digikam experiment establishes most what I was looking for - since the Philips profile causes similar behavior with other software, it's very likely that it's a bad profile. The only difference between photoshop and digikam is that photoshop uses in-house color management routines whereas digikam uses lcms, which is the same library used by mozilla. Thus, it's _conceivable_ that the issue is actually an lcms bug, though highly unlikely.

Either way, this is definitely not a mozilla bug - marking bug as invalid. Thanks for your help reporting and working through the issue promeneur.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
Well the first hint here is that the profile was created 5 years ago. Unless the display has been in storage and not used for 5 years, there's no chance this profile is useful in any event, as the display behavior would have substantially changed in 5 years of use.

Further, "PhLCD17a.icm" describes a pretty messed up display, being black through at the first 20 levels and is generally very dark. Therefore properly functioning CMS will try to compensate by increasing RGB values so it displays correctly. Since the user reports images are washed out, the display probably doesn't behave the way the profile describes. Therefore the profile is invalid for the display being used.
You need to log in before you can comment on or make changes to this bug.