stretched <a> objects display a small dot on the screen when pressing the link.

RESOLVED DUPLICATE of bug 357125

Status

()

RESOLVED DUPLICATE of bug 357125
11 years ago
11 years ago

People

(Reporter: info, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9) Gecko/2008052906 Firefox/3.0

when a webpage uses a <a> tag with for example:

<a href="test.com"><div style="width: 100%;padding: 3px">my text</div></a> 

Firefox will place a small dot on the top of that <a> object when you press the link, this is quite annoying.

I would post a screenshot but there doesn't seem to be an option for that.
but when you go to http://www.google.com
type in any search and scroll down to the bottom.

You will see all the links for all the page numbers, this is a good example of a stretched <a>. when you  press and hold one of those links you will notice that there is a small dot on top of the images visible. It's best visible on the next an previous buttons. The small dot becomes visible above the arrow image.

I uploaded a screenshot to http://www.artfact-design.com/puntjen.jpg



Reproducible: Always

Steps to Reproduce:
1. create a basic <a> html link.
2. try to expand the <a> element so it becomes a bigger box, other than just around the text
3. example: <a href="http://www.google.be"><div style="height: 20px;width: 200px">Big Button</div></a>
4. Use firefox to open the html page and try to click on the big link, you will see that firefox has trouble with the bigger box and somehow displays a dot in color of the text in the top left corner of the <a> box.
Actual Results:  
You see a stretched <a> object that looks fine, but when you click on that object to "open the page" and hold the mouse down you see a dot in the upper left corner of the <a> object. This is a real problem in some site designs.

Expected Results:  
Don't display a dot in upper left corner. 

I'm sure it has nothing to do with the html code itself because this happens on all websites (ex: google) when for example an <a> object is filled with an image. 
or just set to a larger size.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357125
You need to log in before you can comment on or make changes to this bug.