Valid xhtml Flash syntax not showing Flash movie

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: jyri.kilpelainen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9) Gecko/2008052906 Firefox/3.0

I noticed that Flash movies are not shown with Firefox 3 if they're added with a valid xhtml syntax. The code uses only <object> tag without the <embed> tag as shown in A List Apart (http://www.alistapart.com/articles/flashsatay/) or Ambience.sk (http://www.ambience.sk/flash-valid.htm). Sites like Youtube and Adobe.com work ok so the problem may not be in the Flash player.

Also the Flash movies were displayed properly with Firefox 2. After updating to FF 3 they were not shown anymore.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 3 and Adobe Flash (9.0.124.0).
2. Visit a site with a Flash movie added with valid xhtml syntax. Examples http://www.4f.fi (on the left side should be a Flash movie) or http://www.hurmaavahamina.fi/ (the whole site should be a Flash movie)
3.
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 1

11 years ago
"Bug" fixed. Adblock's most recent version is blocking the Flash movies. Thus the problem is not in Firefox itself.

More info on Adblock: https://addons.mozilla.org/en-US/firefox/addon/10

Comment 2

11 years ago
Correcting resolution.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.