Closed Bug 441149 Opened 12 years ago Closed 12 years ago

Desktop folder moves after dragging a pictured to it

Categories

(Firefox :: Shell Integration, defect, minor)

PowerPC
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 401380

People

(Reporter: jdcrownover, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

On my MacBook Pro I have the desktop set to NOT automatically rearrange the files and folders.  I have one folder specifically for pictures from the web which I add to by simply dragging the picture over to the folder.  To make this really easy, I have located the folder on the LEFT side of the desktop (MAC automatically arranges the folder on the right side) and have my Firefox window offset from the left just enough to make the folder visible.  This setup worked great with my Firefox 2+.

After installing Firefox 3, whenever I drag a picture to the folder, the folder disappears.  I find that it has be automatically re-arranged to the first available spot on my desktop, which is normally under the Firefox window.

I have moved the folder back to where I want it multiple times, but every time I drag a picture to it, it goes back to where it was.

I have verified that this happens with graphics from multiple web sites, so it is not site specific.

I have verified that my desktop has the auto-arrange set to "NONE".

I understand that this would be a VERY LOW priority, but it would be nice if it gets fixed some time in the future.

Reproducible: Always

Steps to Reproduce:
1.Set your desktop "auto-arrange" to NONE.
2.Move a folder to a location away form it's auto-arranged location.
3.Drag a picture from any web site to the folder.
Actual Results:  
1. If you don't already have your desktop icons arranged, right click on the desktop and select "Arrange by " and select an option.  Then, right click the desktop and select "Show View Options".  Next, select the "Arrange by" to be "None". 
2. Select or create a desktop folder to receive your graphics and move it away form its current location to a spot where it will be visible when Firefox is running.  I suggest the left side of the desktop.
3. Open Firefox and go to any web site.  Left click on a graphic of picture, and while holding down the mouse button, drag it to the desktop folder until the pointer is over the folder and the folder is "highlighted", then release the mouse button.

Expected Results:  
Upon the release of the mouse button, the folder will immediately move back to its "arranged" location.

The folder should not have moved.

(Note: The picture DOES get saved to the folder properly, it is just the movement of the folder which is in error.)

Default theme is in use.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401380
You need to log in before you can comment on or make changes to this bug.