Firefox has hijacked control of Dreamweaver CS3 WITHOUT MY PERMISSION!

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Michael Gibson, Unassigned)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I am really, really upset here. Firefox 3.0 has apparently taken over my computer's file extension naming. In Dreamweaver, where the file type is listed, e.g. .jpg, gif, etc. instead of .html, I now have the words 'Firefox Document'. I DID NOT give Firefox permission to do so and I would like instructions as to how to remove this immediately, or I will remove Firefox from my system in hopes it removes it. This is PIRATING control of my computer. This is absolutely unacceptable behavior on the part of Mozilla's programmers!!! I am also going to send this on to Adobe's Dreamweaver team, as I am sure they are going to be very interested in this 

Reproducible: Always

Steps to Reproduce:
1.All I have to do is open Dreamweaver's Files dialog box.
2.
3.



Simply stated .html or .htm or other standard file type naming convention, and not have turned into an advertising forum for Mozilla's Firefox. Firefox DOES NOT OWN HTML!!!
(Reporter)

Updated

10 years ago
Keywords: helpwanted

Comment 1

10 years ago
That's a result of installing Firefox as the default browser on your system. Windows can only install a single application per filetype as the default handler.

Note : if you installed Firefox first, and then Dreamweaver, then you would have the opposite problem !

To fix this, use the the File Explorer from Windows (not Internet Explorer, the window where you can manipulate files). Then select Folder Options under Tools, then File Types. There's a while list of filetypes. Select the filetype you want to change, then click on change. Normally Dreamweaver should be under the list of recommended applications, otherwise select it with the browse button.

It's also possible the there's a function in Dreamweaver to do this faster (some apps do, for instance QuickTime), because these types of conflicts are very common.
Jo explained it, Firefox3 sets itself as default Browser unless you uncheck it.
I can not see a bug here and this is not a support Forum.
If you need additional help use http://support.mozilla.com

marking invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: Security → General
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.