Offline mode heuristic is broken

RESOLVED DUPLICATE of bug 424626

Status

()

Firefox
Shell Integration
--
major
RESOLVED DUPLICATE of bug 424626
9 years ago
9 years ago

People

(Reporter: Jonathan Steinert, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

When using firefox... it will switch to offline mode at times when the machine is quite adequately connected to the internet. Makes user angry when it happens often enough.

Reproducible: Always

Steps to Reproduce:
1. Have network-manager running (doesn't handle dialup connections)
2. Connect to the internet via some other means.
3. Try to open a web page in a running firefox session.
Actual Results:  
Error page:
"Firefox is currently in offline mode and can't browse the Web."

Expected Results:  
The page I tried to load is able to be resolved just fine via DNS, is routable, pingable, and responds to http (or whatever protocol I've requested) requests. Perhaps firefox should actually try to hit the page I've requested, rather than presuming that it's offline and setting itself so.

It should be noted that at no point to I actually tell firefox that it should switch to offline mode... it does this on it's own... I assume by monitoring dbus or something. There is no documentation I can find saying what the actual behavior is.

Or maybe there should at least be a preference to make it stop listening to dbus (if that's what it does)

Comment 1

9 years ago
Firefox is using dbus to query the network connection status. Maybe network-manager is confused in some way and does not report the network as being available when it should. What do you mean by "Connect to the internet via some other means."? Network manager should go online when you have a network cable plugged in on an interface it is monitoring.

You can check network status with the command (as root):

dbus-send --print-reply --system --dest=org.freedesktop.NetworkManager --type=method_call /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.state

A return value of 3 means the network is connected.

If you want to disable NetworkManager (but that would fix the consequence rather that the cause), you can set toolkit.networkmanager.disable to true in about:config.
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
Connecting by another means includes any internet connection that network-manager is unable to grok.

For example, I can connect by ppp<->bluetooth<->cell phone. Most people call this tethering. Network-manager doesn't support this (yet?), so I can't use it to make the connection for me.

The problem I guess would be the fact that when network manager says it's online, it is online. That can be inferred properly. Since network manager isn't the only way to connect towards the internet though, you can't really trust that when it says it's offline that you are actually offline.

Comment 3

9 years ago
Firefox could try to access the network when offline to work around the fact that network manager is not able to detect an active connection.

However, I think it would be better to fix network manager instead of Firefox, because every application would benefit from it.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424626
You need to log in before you can comment on or make changes to this bug.