search bar does not respond to enter

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: a.barcomb, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

When I enter text in the search bar and press enter, the search is not executed.  This does not always happen--if I completely close Firefox and restart it, search will generally work for a while.  However, once it stops working it does not start working again (without a restart) even if new text is entered.  This appears to be the case for both the default search (Google) as well as for the next search engine I tried (Yahoo).

Reproducible: Sometimes

Steps to Reproduce:
1. Enter text in the search bar
2. Hit enter
3.
Actual Results:  
Nothing happens.

Expected Results:  
I'd expect the results of my search to be displayed.

This issue was previously reported as 426329, but instructions on that bug requested that a new bug be filed if the issue was not resolved.  It appeared that issue was believed to be fixed by version 3.0, but that does not seem to be the case.
Bug 426329 is not the same issue, since that was very obvious bustage that caused the search bar to never work. If you're seeing problems intermittently it may be caused by an addon, or perhaps caused by bug 359564. Can you try Firefox safe mode, and/or checking whether you're running out of disk space?
(Reporter)

Comment 2

10 years ago
I am now running firefox in safe mode, and will see if I can replicate the problem.  However, I have not installed any addons and use the default theme, so safe mode should be indistinguishable from my normal environment.

I have confirmed that I am not running out of disk space; df shows 86% capacity in use.  
(Reporter)

Comment 3

10 years ago
Note that I've also reported bug 441511; I don't know if there is a connection between these two issues.
Confirming; just had this happen to me.

Here's the exception:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFormHistory2.addEntry]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: chrome://browser/content/search/search.xml :: handleSearchCommand :: line 443"  data: no]
Status: UNCONFIRMED → NEW
Ever confirmed: true
nsFormHistory::AddEntry only calls a bunch of storage methods, and NS_ERROR_FILE_ACCESS_DENIED maps to SQLITE_PERM or SQLITE_CANTOPEN there. Are you out of disk space, or is there anything else strange about your profile that would make SQLite fail to open the DB?

(Not sure what made you think you're seeing the same problem as the original reporter - just the symptoms?)
Yeah, just the symptoms, and that it happens to intermittently.  Not out of disk space, and I can't bring to mind anything out of the ordinary about my profile; the only extension I'm "using" is Selenium IDE.
(Reporter)

Comment 7

10 years ago
After several days of running in safe mode (I haven't restarted Firefox since the 24th of June, I had the same problem with the search bar.  I had visited the page http://www.babynamenetwork.com/baby_names/detail.cfm?name=Jin&gender=Female and then typed 'jin name' in the search bar.  I hit enter and it did not submit the query.  I clicked on the words again, and again hit enter, and again it did not submit the query.  After I opened a new tab, then returned to the original tab, clicked on the search bar, and hit enter, the query was executed.  This is somewhat different from what happened the first time, when I couldn't get it to submit no matter what.  I will keep running this instance of Firefox to see if I can get any more information.
(Reporter)

Comment 8

10 years ago
...and a few minutes later I have replicated my earlier problem.  No matter what I try, I can't get the search bar to work now.  I'll keep Firefox until tomorrow in case there's some information I can extract for someone.
Can you try setting javascript.options.showInConsole and browser.search.log to true using about:config, and check whether there are any relevant messages in the Error Console after you've reproduced the problem?
(Reporter)

Comment 10

10 years ago
I tried to open Tools/Error Console but it would not launch.

This instance of Firefox has deteriorated further since yesterday.  This morning I had two tabs already open.  I opened a third and was able to use it, but when I tried to open a fourth tab (either by opening it and typing in a URL, or by opening a link in a new tab) the page would not load.  The URL appears in the URL bar, and 'Done' appears on the bottom of the browser, but no content appears on the page, and the document is described as (Untitled).

I then closed the third tab and opened a new third tab, which behaved just like the fourth tab I had tried to open earlier.  At this point I thought that the issue was that only existing tabs worked, but then I proceeded to click on a link in my first tab (www.doonesbury.com/strip/dailydose).  This worked, but when I tried to enter a URL (google.com) directly into the URL bar, it did not load or even appear to load.  I then went back to the original page in that tab (a local file) and tried to click on another link (www.userfriendly.org) but the page did not load.  Doonesbury will still load, however, so it is probably able to load from cache if not from the internet.

At this point, the browser is pretty much unusable, and I have no idea how I can get some useful error information out of it for you.

Comment 11

10 years ago
abarcomb, nothing in the console log?(In reply to comment #10)
> I tried to open Tools/Error Console but it would not launch.

do you think this is Mac Bug 324334 – Cannot switch to Error Console in the "Window" menu
(Reporter)

Comment 12

10 years ago
I just read that bug but it doesn't sound very related to me.  I can select the search bar, because I can enter things into it, I just can't get it to perform a search.  Several other problems develop later on, such as being unable to open the error console (it isn't grayed out or anything, it's just that nothing happens after I click on it) and then the issue with the tabs I described.  The basic symptom is that the browser becomes more and more broken until I give it a mercy kill, which isn't something I saw described in the other bug report.

Comment 13

10 years ago
I don't mean 324334 as related to search - but related to your inability to launch error console. 
(Reporter)

Comment 14

10 years ago
It appears unrelated.  In 324334 the user has already opened the console, then accessed another window, and then tries to bring the console to the forefront by opening it again.  

What I have isn't a focusing issue.  I can't launch the error console at all when the browser is in this state (it isn't already open).  It only becomes impossible to open the error console when a whole host of other problems have developed, and it takes several days of running the browser to recreate the problem.  It seems more like a general meltdown which affects search, tabs, and the error console than anything specifically related to the error console.  Unfortunately it never actually crashes, so I'm unable to give anything other than a description of what seems to be happening.
Reporter, can you please try to create a fresh profile? Follow these instructions to have a test if it can be reproduced there:

http://support.mozilla.com/en-US/kb/Managing+profiles
There were a couple of instances of this last week in the support forum from 3.1 users.
https://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=298024
https://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=299578

One instance, the OP said the problem went came back after restoring "formhistory.sqlite" in a new profile.
(In reply to comment #16)
> One instance, the OP said the problem went came back after restoring
> "formhistory.sqlite" in a new profile.

That seems likely to be caused by the bug described in bug 472064 comment 5. Nightly or beta users that switch back and forth between old and new builds might run into trouble. There's a manual workaround in bug 472064 comment 1, but otherwise the only solution is to get rid of the bad formhistory.sqlite.
(Reporter)

Comment 18

10 years ago
I'm now using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1 and I haven't had this problem at all in this version.
(In reply to comment #18)
> I'm now using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US;
> rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1 and I haven't had this problem at
> all in this version.

This version is really outdated. You should upgrade to the latest one to have a more secure web experience. But as said it seems that the bug has been solved. Marking as WFM. Reporter, if you can still see it with Firefox 3.0.11 or Firefox 3.5 feel free to reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.