If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Only display HTML source code

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: LaoWei, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

This is a Chinese website. It only support IE for the online account verification.
I remembered the FireFox beta 1 can display the web page. But the FF3 only display the HTML source code.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

9 years ago
I just tried a RC version (Created on 05/29).  It is OK.

Updated

9 years ago
Severity: normal → major

Comment 2

9 years ago
The last Release Candidate (RC3) *is* the final version. Look at the build-date : they're both May 29th.

The problem is due to a misconfiguration of the webserver, which uses the text/plain MIME-type instead of text/html (Firefox respects that setting even if it's incorrect, IE ignores it). The reason that you saw it with one version, and not with the other one, might be due to load balancing : maybe there' 1 webserver out of a series that is misconfigured. Or maybe it was fixed in the mean time.

It works for me with Firefox 3.0 final on Windows XP.

Comment 3

9 years ago
They seem to have fixed this. I also saw the source before due to text/plain. But now I see the page.

Updated

9 years ago
If you still see this use shift+reload or clear the cache
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.