Last Comment Bug 441888 - ARIA checked menu items are not included in the total list of menu items
: ARIA checked menu items are not included in the total list of menu items
Status: VERIFIED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: 1.9.0 Branch
: x86 Windows XP
: -- normal (vote)
: mozilla1.9.1a1
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
http://archive.dojotoolkit.org/dojo-2...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-25 13:14 PDT by Becky Gibson
Modified: 2008-07-17 07:22 PDT (History)
2 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.67 KB, patch)
2008-06-26 03:33 PDT, alexander :surkov
no flags Details | Diff | Splinter Review
patch2 (6.05 KB, patch)
2008-06-26 04:22 PDT, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description Becky Gibson 2008-06-25 13:14:00 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0pre

The example url has a context menu with 11 items.  The first 8 are standard menuitems, the last three are checkable menuitems.  The Accessible description for the first 8 are "x of 8" where x is the position of the menuitem in the list of items.   There is no description for the 3 checkable menuitems. Since they are included within the same menu, they should also be counted. 

Note that you can also substitute "nightly" in the above url in place of "dojo-2008-06-25" to get the most up to date test file if you are brave.

Reproducible: Always

Steps to Reproduce:
1.Open inspect32 or other tool to view MSAA information - set it up to track keyboard focus
2.Open the above url
3. put focus in the first text box on the page
4. press shift-F10 to bring up the context menu. 
5. arrow down to the menu item "cut", notice that the description in IA2 is listed as "4 of 8"
6. arrow down to the menu item labeled "checked", notice that there is no description. I think it should be "9 of 11"


Expected Results:  
description for "checked" menu item should be "9 of 11"
Comment 1 Marco Zehe (:MarcoZ) 2008-06-26 01:50:31 PDT
Confirmed.

Becky, is there a separator below the 8th menu item (where it stops counting) and above the checkable items?

I've done a test on the regular Firefox View menu, and noticed that I'm getting a higher count (13 items in my case) than are actually visible, and I am wondering whether we are counting separators in this case, but on the sample page, are thinking that at the separator, the menu ends.
Comment 2 Aaron Leventhal 2008-06-26 02:55:08 PDT
For any changes we make to ARIA processing, please update this doc:
http://developer.mozilla.org/en/docs/ARIA_User_Agent_Implementors_Guide
Comment 3 alexander :surkov 2008-06-26 03:33:53 PDT
Created attachment 326879 [details] [diff] [review]
patch
Comment 4 alexander :surkov 2008-06-26 04:22:36 PDT
Created attachment 326885 [details] [diff] [review]
patch2
Comment 5 Marco Zehe (:MarcoZ) 2008-06-26 14:06:45 PDT
Is this patch meant to stop counting on a snormal separator, for example as seen in Firefox's "View" menu?
Because with this patch applied, it still has 13 items (10 items plus 3 separators), and the description still says "1 of 13, 2 of 13, 3 of 13, 5 of 13".
Comment 6 Becky Gibson 2008-06-26 19:09:02 PDT
In answer to the question of the separators.  The are three separators in the menu. There are two which are not counted (based on the code when I submitted the bug) within the first 8 items. In other words, there are eight actual menu items and 2 separators.  Then there is a separator created in the same manner as the others, then the 3 checkable menu items.  I don't think that separators should be counted since they are never navigated to.
Comment 7 alexander :surkov 2008-06-26 21:50:15 PDT
Technically in the example those separators aren't separators in a11y terms (they haven't role separator and they are exposed as role nothing). I really haven't idea why they are counted (because we count only accessibles with the same role). So the question is for Becky: what the difference is between our example in mochitest (see the patch2) and your example?

Marco, why the bug is fixed?
Comment 8 Marco Zehe (:MarcoZ) 2008-06-26 22:48:45 PDT
(In reply to comment #7)
> Technically in the example those separators aren't separators in a11y terms
> (they haven't role separator and they are exposed as role nothing). I really
> haven't idea why they are counted (because we count only accessibles with the
> same role). So the question is for Becky: what the difference is between our
> example in mochitest (see the patch2) and your example?

Alex, the ARIA menu that Becky linked to now works correctly with your patch, it counts 11 items.

However, in our own View menu, we also count the separators. Look at the "View" menu in DOM inspector. The patch hasn't changed that, although I thought it would. Or did you not intend to also change regular menus that have separator accessibles?

> Marco, why the bug is fixed?

With your patch, the ARIA bug is indeed fixed. I am just wondering whether this patch also should address regular menus or not.
Comment 9 alexander :surkov 2008-06-26 23:17:05 PDT
No, it shouldn't address the original xul:menu, please file another bug for this.

Marco, did you land the patch if you marked it as fixed? You didn't set r+ in any way and fixed looks strange :)
Comment 10 Marco Zehe (:MarcoZ) 2008-06-26 23:34:43 PDT
Oops, thanks for the pointer! I must have accidentally hit that radio button somehow.
Comment 11 Marco Zehe (:MarcoZ) 2008-06-26 23:43:07 PDT
Comment on attachment 326885 [details] [diff] [review]
patch2

r=me
Comment 12 Marco Zehe (:MarcoZ) 2008-06-27 23:20:32 PDT
Pushed to mozilla-central in changeset:
http://hg.mozilla.org/mozilla-central/index.cgi/rev/e4d8bb043ef7
Comment 13 Marco Zehe (:MarcoZ) 2008-06-29 03:35:32 PDT
Verified fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008062804 Minefield/3.1a1pre.

Note You need to log in before you can comment on or make changes to this bug.