There is a problem with the generation of the Base URI when using scripts for a file:/// access

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: price, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The above URL works, but... if you have the same files in the same structure on a local machine and reference it with:
file:///C:/Documents%20and%20Settings/Pictures/Test/thumb.html
It then appears that in the <script> created page the base URI is the URI of the file you first opened. I.e. If I start with Test/thumb.html, click on the image to get Test/Bama/thumb.html -- the image is displayed, but click on the image it is an error, with the image name as: Test/Scan5451-SM.jpg, not Test/Bama/Scan5451-SM.jpg

Reproducible: Always

Steps to Reproduce:
1. Open local file: file:///C:/Documents%20and%20Settings/Pictures/Test/thumb.html
2. Click on Image (gets Test/Bama/thumb.html)
3. Click on Image to get larger view.
Actual Results:  
1. Works
2. Works
3. Error -- Image name is given as: Test/Scan5451-SM.jpg
Not as Test/Bama/Scan5451-SM.jpg


Expected Results:  
See actual. The results on a web access are right. It is only on a local file:/// access that it fails.
(Note this has worked in the past under Firefox 1.0,2.0, MSIE 6, Safari.)

For reference a zip file of the Test directory used above is:
http://www.visionbib.com/Test/Test.zip

It is either some problem with the URI, Base URI (I tried various base settings and did not get any change in the error), or an interaction with the SCRIPT -- the new window is computed and images referenced in files at all levels seem right.
Note the location bar that is on the computed window reflects this problem -- no matter what page is displayed, the first page you viewed is given (for file:/// access), for http:// access you get the current displayed page (page displayed in the browser, not the computed file.) So that if I first open Test/Bama/thumb.html, then click on the image, it opens a new window with the image.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 2

8 years ago
Somewhere in the update sequence it did get fixed (which version is not clear, but it doesn't really matter).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.