caldav and ics calendar aren't disabled after canceling the login dialog

RESOLVED FIXED in 1.0b7

Status

RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: andreas.treumann, Assigned: Fallen)

Tracking

unspecified
1.0b7
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
STEPS TO REPRODUCE:
===================

- use caldav server http://rscds.zathras.lss.wisc.edu/caldav.php/mozilla/home/
- don't save user/password 
- restart thunderbird/lightning
- click 'cancel' in the login dialog

RESULT:
=======

- the caldav calendar is not switched off

EXPECTED RESULT:
================

- the caldav calendar should be switched off

REPRODUCIBLE:
=============

- always
Component: General → Provider: CalDAV
QA Contact: general → caldav-provider
Wow, this one is really annoying. I want this for 1.0
Flags: wanted-calendar1.0+

Comment 2

9 years ago
Note that the patch for bug 435854 should make this a lot less annoying: Instead of re-prompting immediately for the password, it will re-prompt at the next refresh or at the next manual reload which I think is an acceptable behavior, at least it gives the user the chance to go and disable the calendars he doesn't want.
(Assignee)

Updated

9 years ago
Flags: wanted-calendar1.0+ → blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact]
(Assignee)

Updated

8 years ago
Whiteboard: [not needed beta][no l10n impact] → [needed beta][no l10n impact]
Taking this off the needed-beta list due to the previous comment and lack of time.
Whiteboard: [needed beta][no l10n impact] → [not needed beta][no l10n impact]
Created attachment 549083 [details] [diff] [review]
Fix - v1

This takes care, not only for caldav but also for ics.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #549083 - Flags: review?(nomisvai)
(Assignee)

Updated

7 years ago
Summary: caldav calendar isn't switched off after canceling the login dialog → caldav and ics calendar aren't disabled after canceling the login dialog
Whiteboard: [not needed beta][no l10n impact] → [not needed beta][no l10n impact][needs review]
(Assignee)

Updated

7 years ago
Attachment #549083 - Flags: review?(nomisvai) → review?(matthew.mecca)
Comment on attachment 549083 [details] [diff] [review]
Fix - v1

Looks good. r=mmecca
Attachment #549083 - Flags: review?(matthew.mecca) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/2d09dbd96fcd>
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to comm-aurora <http://hg.mozilla.org/releases/comm-aurora/rev/8e731eb1d074>
Target Milestone: Trunk → 1.0b6
(Assignee)

Updated

7 years ago
Whiteboard: [not needed beta][no l10n impact][needs review] → [needed beta][no l10n impact]
You need to log in before you can comment on or make changes to this bug.