<select> doesn't show background-image

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: dominik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9) Gecko/2008061015 Firefox/3.0

<select> elements don't show background-image as long as background-color is anything else than transparent

Reproducible: Always

Steps to Reproduce:
Try the following code:
=========
<style>
.image {
    background-image: url(ajax-loader-small-aktiv.gif);
    background-repeat: no-repeat;
    background-attachment: scroll;
    background-position: 50% 50%;
    background-color: #fff;
}
</style>

<select class="image">
    <option>Option</option>
</select>

<input type="select" class="image" value="Input" />
====


The image here is a animated gif, i have also tried it with a (transparent) png and a non-transparent jpeg file. All results were the same
Actual Results:  
The select field doesn't show any background-image whereas the input does.
If you however set the background-color to "transparent", you can see the image in the select field as well

Expected Results:  
select should show the image without having to have a transparent background
(Reporter)

Comment 1

11 years ago
I have also just checked it on a Firefox 2 and Firefox 3 installation on windows, they both show the same behaviour
Works for me on trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.