Closed Bug 442214 Opened 13 years ago Closed 13 years ago

Main password dialog for each tabbed page

Categories

(Toolkit :: Password Manager, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: tvrdik, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061912 Mandriva/3.0-3mdv2008.1 (2008.1) Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061912 Mandriva/3.0-3mdv2008.1 (2008.1) Firefox/3.0

When FF start with history and have main password for protection password manager, display dialog for entering main password for each page which need access to password manager.

Reproducible: Always

Steps to Reproduce:
1. Set main password
2. Save password on some pages
3. Open the pages in tabs
4. Change settings - Main / Startup / When Firefox starts / Open latest pages in tabs
5. Close / Open the Firefox

Actual Results:  
After load pages with save password. Firefox open more main password type dialog.

Expected Results:  
Synchronized access into password manager or block loading page when Firefox starting - next page should load after loaded previous page.

May be duplicate with #440844

I can reproduce in version 2.0.x a 3.0.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.