If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copying text from web pages sometimes copies a new line

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
9 years ago
a year ago

People

(Reporter: Soad Link, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

On certain web pages (those with the .txt extension from what I've tested), when you highlight certain text by double clicking on it, and then copy it (ctrl+c), it will copy a new line along with the text.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to the following site: http://aluigi.altervista.org/adv/sunagex-adv.txt
2. Double click on the word "SunAge" on the 5th line to highlight just that word.
3. Press CTRL+C to copy that word
4. Open a text editor such as notepad, and press ctrl+v to paste the text you just copied.
Actual Results:  
You will notice that not only did it copy the word, it copied a new line too.

Expected Results:  
It should only copy the word, considering that is what is highlighted. Not a new line.

It seems to only do this in .txt files from what I have found. It never did this in versions of Firefox 2.
Confirmed with latest trunk on Windows XP. Regression range is:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1182366840&maxdate=1182369239
Caused by Bug 385123 or Bug 367177?
Blocks: 367177
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Flags: wanted1.9.1?
Flags: wanted1.9.1? → wanted1.9.1+

Comment 2

a year ago
Not reproducible with latest Nightly and release.
Considering this, I will mark this issue as Resolved-WORKSFORME. If anyone can still reproduce it, feel free to reopen the issue and provide more information. Thanks

--
Version 	48.0a1
Build ID 	20160422030223
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.