Closed Bug 44232 Opened 20 years ago Closed 17 years ago

Mis-matched fonts have poor underlining result

Categories

(SeaMonkey :: Sidebar, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1777
Future

People

(Reporter: oliver, Assigned: ftang)

References

()

Details

In Sidebar, select Add -> Customize and open 'customize sidebar' dialog.

I am making language pack for Japanese, and translated 'customize'.
And, 'sidebar' is checked to 'DONT_TRANSLATE'.

Then, 'customize' and 'sidebar' are displayed by using different fonts.
These words have displayed with underline, but it's shifted.

I put a picture, please check URL.
I'm going to confirm this bug but L10n is probably not right 
area to assign this bug. 
Let me first send this over to steve who has done the most in
the sidebar customize.xul file. CC'ing also ben who has modified
this file recently.

The problem is best described by looking at the image at the above URL.

When we localize the the title, "Customize Sidebar" into
Japanese, the underline which comes under the Japanese part
is not aligned correctly with the underline part for the English
part "Sidebar". I guess this title comes from this line:

<box class="box-header" id="header" value="&sidebar.customize.title.label;"/>

in the file.

I've looked at this biefly in HTML composer but in there if we
type in the same set of characters and underline them, it does not
look this bad. (This partially depends on what font family types 
we use of course.)
One possibility is not to use the underline for this -- at least
for Japanese and other languages in which Asian and ASCII
fonts need to be mixed. "Sidebar" is a component name and we 
don't translate it. There is such an example where an underline
is not used. See the Customize dialog window for
View | Character Coding menu. There we essentially use the same
Sidebar customize window template but the title part uses a
different style (and type.)

Presumably we can somehow fix this with an CSS change?


Status: UNCONFIRMED → NEW
Component: Localization → Sidebar
Ever confirmed: true
QA Contact: teruko → blee
Summary: Underline is shifted by using Japanese font → Underline comes out jugged when English & JPN texts are mixed on Customize Panel title
This time, sending it to slamm for sure.
Assignee: rchen → slamm
not sure what we can do here besides cleaning up the content
to ? use the same language.  why is sidebar marked "do not translate"?
m19
Summary: Underline comes out jugged when English & JPN texts are mixed on Customize Panel title → Mis-matched fonts have poor underlining result
Target Milestone: --- → M19
One simlple solution would be not to use underline here. 
"Sidebar" is a proprietary pdt feature name - sort of like trade mark/name - 
that's why it should not be translated.
I talked to ben about thi sporblem today.
The default font for UI is sans-serif and so the problem
can be sumamrized as follows.

When you have a box-header element which has the following type of
title:

  Sidebar JPN_string (for "Settings")

as the translation of "Customize Sidebar", the English part (Sidebar) 
uses sans-serif (Arial, Helvetica) font while the JPN_string part
uses serif type Japanese font. The udnerlines for these 2 words
do not match in this condition.
This problem can be replicated if you type in the above string
in Japanese in HTML Composer and then change the font type of the
English part "Sidebar" to Arial/Helvetica while leaving the 
JPN_string alone. If you then put underline for the whole
phrase, you get exactly the same effect as the image at the URL.

Ben was leaning toward this being a proble caused by 
havign 2 different default font types -- for Latin characters,
it is sans-serif while for Japanese it is serif/mincho type. 
There seems to be no specific font type definitions in .css
file (e.g. intl.css) that cause this problem. 

Thus this is most likely to fall in erik's expertise area.
I'm going to re-assing to this to erik.
Ben, if you have other thoughts, let us know.
the 
Assignee: slamm → erik
If both the "Sidebar" and the Japanese text could be placed in the same element
so that they use the same font, the underlines will match up. This does mean
that the "Sidebar" would be in the Japanese font, which may be slightly uglier.
Where are these strings located? I'm offering to try it out to test my
suggestion.
Status: NEW → ASSIGNED
Target Milestone: M19 → Future
It's this entity:

<!ENTITY sidebar.customize.title.label ....

in the file

chrome\locales\ja-JP\communicator\locale\sidebar\customize.dtd
Changing QA Contact to andreasb@netscape.com.
QA Contact: blee → andreasb
qa=jonrubin@netscape.com
QA Contact: andreasb → jonrubin
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED
mass change, switching qa contact from jonrubin to ruixu.
QA Contact: jonrubin → ruixu

*** This bug has been marked as a duplicate of 1777 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
QA Contact: ruixu → ylong
Mark as verified.  The URL in this bug is not available any more so I can not
see what's the real problem, also the problem in bug 1777 was resolved. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.