Status

()

Firefox
File Handling
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: David Thiery, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The other day, while I was adding an “extension” to Firefox 3.0, I’ve accidentally closed the session in the middle of its download. When I retry the update again, it didn’t really download anything, instead it was trying to retrieve the file from its cache. Since I know the download did not completed successfully, I didn’t really trust the contents from its cache, so I manually deleted the partially completed download.  However, I did not delete any of its cache indexes and mappings because they were still in use. 

When I retry the download again, it was giving me a new message stating that the target file cannot be found. Because of the cache indexes and mappings were not deleted, it was still trying to access the file directly from its local drive rather than from the Internet source. I think this is a software bug since if the target file does not exist even though its mappings and indexes still do, it should automatically retrieve a fresh copy from its original source. In order to recover, I had to terminate the Firefox processes and then do a manual deletion of the cache indexes/mappings and everything was working again.    


Reproducible: Always

Steps to Reproduce:
1.perform partial download + uninstall the new extension
2.manual delete partial download file from the local cache, but NOT the indexes/mappings.
3.retry to update the new extension.
Actual Results:  
File not found message.

Expected Results:  
Should have retrieve file from the Internet source.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Do not manually edit/delete in the Firefox cache, you will break it b.
It's not supported that a user does this.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.