Firefox gets sluggish and seems to pause every so often if KOL Chat is left open for a while

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: bonusfrogs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

After logging into KOL and opening up LoathingChat and leaving it open for a while (preferably while listening to active channels like /newbie), Firefox will pause every so often and not accept keyboard input or respond to mouse clicks--but will "catch up" to itself after a bit so no keystrokes or mouse clicks are lost. This pausing behavior happens in all Firefox windows and not just the frame or window that lchat.php is in.

Reproducible: Always

Steps to Reproduce:
1. Log in to KoL at http://www.kingdomofloathing.com/ . 
2. Click on "Enter the Chat" in the frame on the right.
3. Wait a bit for people to chat and fill the chat pane up so you need to scroll up quite a bit to see everything. You'll need to keep typing things in chat every 15 minutes or so to keep the connection alive.
Actual Results:  
Notice occasional pauses in responsiveness to mouse and keyboard input in any Firefox window.

Expected Results:  
Should remain responsive at all times to mouse and keyboard input.

I've noticed this bug on my Vista machine, even after a fresh reinstall of the OS. However, it doesn't seem to turn up on my Ubuntu, XP, or OS X machines.

Additionally, this bug didn't happen on Firefox 2 on my Vista machine, either.
(Reporter)

Comment 1

10 years ago
Created attachment 327342 [details]
A copy of the lchat.php page that causes the sluggishness

Comment 2

10 years ago
Try running Firefox in safe mode.
Safe Mode is a special way of running Firefox that temporarily disables extensions, themes and toolbar changes.
Full safe mode instructions are at http://support.mozilla.com/kb/Safe+Mode.
(Reporter)

Comment 3

10 years ago
Still happens in Safe Mode.
(Reporter)

Comment 5

10 years ago
Still happens in a fresh profile.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 8

8 years ago
Sorry for being late to the party. A freshly-downloaded and -installed copy of 3.6.12 with a fresh profile doesn't exhibit this behavior anymore.
OS: Windows Vista → Windows 2000
Resolution: INCOMPLETE → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.