bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

I can play video on all websites except for CNN video, I switch back to Firefox and CNN Video now plays.




10 years ago
8 years ago


(Reporter: Alex Marinakis, Unassigned)


Firefox Tracking Flags

(Not tracked)


(Whiteboard: [closeme 2010-09-15], URL)



10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20080404 Firefox/
Build Identifier: Firefox/3.0

I can play video on all websites except for CNN video, I switch back to Firefox and CNN Video now plays.

Reproducible: Always

Steps to Reproduce:
1.Just access cnn video, screen remains black and video never plays. (Firefox 3.0)
Actual Results:  
No video!

Expected Results:  
Played video.

New browser seems faster, but you should make all add-ons compatible before you offer the download.  

Downloading and using Firefox right at this time has been nothing but a headache!
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

This works fine for me with a spoofed user agent string, so this is probably a matter of wrong browser sniffing.
In about:config, make a new pref with the name general.useragent.override and a value of (for example) Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20080311 Firefox/
Whiteboard: [DUPEME]

Comment 2

10 years ago
Might be a dupe of bug 427382 ?

Comment 3

10 years ago
Assuming this is the CNN video found at http://www.cnn.com/video/ that now uses flash to play, I've found this is a case of bug 365772. Specifically, the javascript behind their player uses window.globalStorage. If I have my cookie expiration policy set to "Always Ask", then attempts to access storage result in a security exception (visible in the Error Console) and the video and other data never loads. If I set the policy to "Keep until they expire", everything loads fine.

Comment 4

10 years ago
Thanks for your reply, but uninstalling Google toolbar fixed the problem for me.

Comment 5

10 years ago
I don't have Google toolbar. In fact, I should point out I'm running on Mac OS X.

Comment 6

8 years ago
Do you still see this problem using the most recent versions of all components (application, plugins and add-ons)?

If you do not, please close the bug with resolution set to WORKSFORME. If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [DUPEME] → [closeme 2010-09-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.