Drag folder alias to browser -> empty directory listing

RESOLVED WONTFIX

Status

Core Graveyard
File Handling
P3
normal
RESOLVED WONTFIX
18 years ago
2 years ago

People

(Reporter: Eli Goldberg, Assigned: Bill Law)

Tracking

Trunk
Future
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Drag folder alias to browser -> empty directory listing

* STEPS TO REPRODUCE
0) Launch Seamonkey
1) Drag an alias to a folder onto your browser window.
(e.g. follow the steps on <http://www.mozilla.org/quality/browser/front-end/
testcases/drag-drop/drag-fld-desktop-browser/drag-fld-desktop-browser-d.html>)

* RESULT
 - What happened

The browser window displays an empty file listing.

 - What was expected 

Browser window should display a listing of the folder content.

* REGRESSION

 - Occurs On
        Mac OS Seamonkey (6.29.2000 optimized build)		

 - Doesn't Occur On
        Win32 Seamonkey (6.29.2000 optimized build [NT 4, Service Pack 5]) --- 
drag to browser not yet supported



* CONFIGURATIONS TESTED

- [Mac] Power Mac G4 (450 Mhz), 256 MB RAM (VM off), 1024x768 (Thousands of 
Colors), Mac OS 9.0

- [Win32] Vectra VL (266 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
doesn't appear like we follow aliases when resolving directories. we seem to 
resolve aliases correctly in the case where you drag a file alias into navigator, 
so i don't think the problem is in any of the toolkit code.
Assignee: pinkerton → gagan
Component: XP Toolkit/Widgets → Networking
Keywords: nsbeta3
(Reporter)

Comment 2

18 years ago
qa assigning to self.
QA Contact: jrgm → elig

Comment 3

18 years ago
Not sure why this is networking. But cc'ing rjc for his interest. 

Comment 4

18 years ago
ok RJC wants it!
Assignee: gagan → rjc

Comment 5

18 years ago
per triage team, not critical for beta3 :(
Whiteboard: [nsbeta3-]

Updated

17 years ago
Target Milestone: --- → Future

Comment 6

17 years ago
file/ftp->dougt
Assignee: rjc → dougt

Updated

17 years ago
QA Contact: elig → tever

Updated

17 years ago
Blocks: 62354

Comment 7

17 years ago
I am not sure how exactly this is related to file or ftp.  Reassigning to mike.

Mike, aren't you the D&D King?
Assignee: dougt → pinkerton
Component: Networking → Browser-General

Comment 8

16 years ago
-> file handling
Assignee: pinkerton → law
Component: Browser-General → File Handling
QA Contact: tever → sairuh

Comment 9

16 years ago
unblock 62354.
No longer blocks: 62354
QA Contact: sairuh → petersen

Comment 10

15 years ago
Alias drag displays the directory symlink-style in Mach-O 20030227.

Mozilla CFM build is dead.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.