Unnecessary crash report upon closing Firefox

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
9 years ago
6 years ago

People

(Reporter: Kat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

Every time I exit Firefox, it tells me that it has "crashed" and asks if I want to report the problem. I exited Firefox myself, and yet it's acting as though I hadn't done it- treating it as an error. This notification is from Firefox, and not my OS.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Exit Firefox (X-out or File:Exit)
3.(this is where the crash screen appears)
Actual Results:  
Firefox crash window appears.

Expected Results:  
Not shown me an unnecessary crash report.

Comment 1

9 years ago
What extensions are you running ? It seems one of them caused a problem when you try to exit the application.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> What extensions are you running ? It seems one of them caused a problem when
> you try to exit the application.


I have one theme running, everything else was incompatible and not kept when I updated to 3.

Comment 3

9 years ago
An application crash during shutdown is still a bug, just like colliding with the front of your garage when you intended to stop anyway is still a bad thing.

Can you load about:crashes and pull out a crash ID so we can look at the stack trace to try to figure out what went wrong?

Comment 4

9 years ago
why i had been kicked out from the cc list? :(

Comment 5

9 years ago
dunno, michabailey did it, afaict it should be prohibitively expensive to remove someone from the cc list while adding yourself.

michabailey: how / why did you do this?

Comment 6

9 years ago
I didn't!

Comment 7

9 years ago
The same happens to me. Each time I close the browser (Firefox 3.0.5) a crash window appears. My OS is Windows XP SP3. This didn't happen with the previous versions nor with the nightly ones.

Comment 8

9 years ago
(In reply to comment #3)
> An application crash during shutdown is still a bug, just like colliding with
> the front of your garage when you intended to stop anyway is still a bad thing.
> 
> Can you load about:crashes and pull out a crash ID so we can look at the stack
> trace to try to figure out what went wrong?

As the same issue happens to me I followed your advise and I'm copying the last Crash ID below.
I hope it helps you!
Should you need any additional information, please post it here.

Firefox 3.0.5 Crash Report [@ GCGraphBuilder::NoteXPCOMChild(nsISupports*) ]
ID: 26e03d51-7765-43c2-a439-75be72081222
Signature: GCGraphBuilder::NoteXPCOMChild(nsISupports*)

    * Details
    * Frames
    * Modules
    * Raw Dump

Signature	GCGraphBuilder::NoteXPCOMChild(nsISupports*)
UUID	26e03d51-7765-43c2-a439-75be72081222
Time	2008-12-22 17:05:18-08
Uptime	29277
Last Crash	59978 seconds before submission
Product	Firefox
Version	3.0.5
Build ID	2008120122
Branch	1.9
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x30c3ed0
Comments	closing 3.0.5..... as usual..... when are you going to solve this..., if ever???? Don't tell me I'll have to wait till next version??? Or worse, till the definitive 3.1???
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	GCGraphBuilder::NoteXPCOMChild 	mozilla/xpcom/base/nsCycleCollector.cpp:1394
1 	xul.dll 	nsCycleCollector::MarkRoots 	mozilla/xpcom/base/nsCycleCollector.cpp:1513
2 	xul.dll 	nsCycleCollector::BeginCollection 	mozilla/xpcom/base/nsCycleCollector.cpp:2368
3 	xul.dll 	XPCCycleCollectGCCallback 	mozilla/js/src/xpconnect/src/nsXPConnect.cpp:440
4 	js3250.dll 	js_GC 	mozilla/js/src/jsgc.c:3247
5 	js3250.dll 	JS_GC 	mozilla/js/src/jsapi.c:2469
6 	xul.dll 	nsXPConnect::Collect 	mozilla/js/src/xpconnect/src/nsXPConnect.cpp:529
7 	xul.dll 	nsCycleCollector::Collect 	mozilla/xpcom/base/nsCycleCollector.cpp:2250
8 	xul.dll 	nsCycleCollector_shutdown 	mozilla/xpcom/base/nsCycleCollector.cpp:2932
9 	xul.dll 	NS_ShutdownXPCOM_P 	mozilla/xpcom/build/nsXPComInit.cpp:783
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.