Closed Bug 442651 Opened 12 years ago Closed 12 years ago

No organizer in the attendees dialog

Categories

(Calendar :: Provider: WCAP, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

Details

(Keywords: regression)

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create an new all day event in your WCAP calendar
- open the attendees dialog
- try to invite someone

RESULT:
=======

- no organizer visible
- it's not possible to close the attendees dialog after inserting some names
- free/busy grid stays empty

EXPECTED RESULT:
================

- the organizers name should be visible
- it should be possible to invite people

REPRODUCIBLE:
=============

- always
Error console:

Error: organizer.commonName has no properties
Source File: chrome://calendar/content/sun-calendar-event-dialog-attendees.xml
Line: 240

Error: inputField.attendee has no properties
Source File: chrome://calendar/content/sun-calendar-event-dialog-attendees.xml
Line: 480
I changed the issue title (first one was not correct)

And better STRs:

- open File/New/Event
- open the attendees dailog -> organizer is empty. Inserting a name and attendees and clicking 'Close' leads to errors 

Last version without this bug 20080626
first version with this bug 20080627 -> possible caused by checkin bug 370150
Summary: WCAP all day events: Can't invite attendees → No organizer in the attendees dialog
Flags: blocking-calendar0.9+
Keywords: regression
Attached patch fixSplinter Review
Attachment #328391 - Flags: review?(philipp)
Comment on attachment 328391 [details] [diff] [review]
fix

Looks good, r=philipp (Welcome back! :-)
Attachment #328391 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in lightning build 2008070803 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.