Firefox is "stuck" in offline mode.

RESOLVED DUPLICATE of bug 424626

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 424626
10 years ago
10 years ago

People

(Reporter: Tj Wilson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061017 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061017 Firefox/3.0

Firefox is stuck in "offline" mode.  This is shown under File ! Work Offline.  I deselect Work Offline and Firefox works normally.  (I have two network interfaces, the first is not connected.)  The problem does not go away if Firefox is restarted, by logging off, or by rebooting the computer.  

Reproducible: Always

Steps to Reproduce:
1.  Start Firefox.  Firefox has started with "Work Offline" checked.  
2.  Uncheck "Work Offline."  Firefox works normally.
3.  Restart Firefox.  Firefox starts with Work Offline checked.
Actual Results:  
Firefox starts offline.

Expected Results:  
Firefox starts without "Work Offline" checked.
This looks like bug 424626. Do you have NetworkManager installed and is it either unconfigured or not controlling the active connection?
(Reporter)

Comment 2

10 years ago
Closing NetworkManager solved the problem.  Apparently many wireless devices don't work well with NetworkManager, and so it's unable to manage the devices, and can't tell what state they're in. NetworkManager can only answer yes or no to the question "Is the network up?". If it doesn't know, it answers no.  Hence, Firefox reports and acts as though it is offline.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424626
You need to log in before you can comment on or make changes to this bug.