CPU use very high on OS X 10.4.11 due to Forecastfox extension

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Randy Pelletier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

There are a few high cpu use bugs on a number of different platforms.  Some of these are 432028, 434513 and 439488.  None quite summarize what I'm seeing although 434513 is the closest I've found.

The CPU goes fairly high and grows.  It seems to start when idled for a bit. It will consume CPU and use more and more after each subsequent idle period until it's rather obvious via fans and heat.  The response of the browser does not seem to be impaired when in high cpu state.  CPU doesn't seem to rise or fluctuate beyond normal usage while active.

Plugins include Sage and Forecastfox.

This is on OSX 10.4.11 dual core Intel Powerbook.

If Firefox is up for a while it gets pretty hot... real hot.

Reproducible: Always

Steps to Reproduce:
1. Apart from the obvious I'd have to say start on a 10.4.11 powerbook
2. Install FF similar to above
3. Use it, go away, use it again, repeat

Actual Results:  
Well, a bothersome lack of cpu when I'm off doing other things that might like to use it and a decidedly uncomfortable level of <em>heat</em>

Expected Results:  
A calm, well mannered Firefox browser.  One that will be idle in the face of .. idling.

Other than high cpu on the pc, the browser response and functionality in no way seem to be impaired with regards to normal use.

Comment 1

9 years ago
If you start Firefox in safe mode (which temporarily disables extensions and a few other things), does the problem go away?
(Reporter)

Comment 2

9 years ago
I have not tried.  I will do that.

For an idea of how long it may take to creep up I started firefox about the same time I submitted the issue.  At this time it's use is hovering around 40% with zero web use other than four tabs on bugzilla which I used for issue submission last night and a handful of headline loads in Sage throughout the day.

\r
(Reporter)

Comment 3

9 years ago
Steady at 10% in safe mode.
\r
(Reporter)

Comment 4

9 years ago
Been "testing" individual plugins.

After bumping around a few of my plugins it would appear that ForecastFox plugin is the culprit. (or minimally a large contributor to the problem).

I just got to re-enabling the forecast fox plugin and right out of the gate the low avg is at 15% before I've even touched the web.

Forecast Fox Version 0.9.7.6
(Reporter)

Comment 5

9 years ago
Huh, it would also appear that enabling Forecast Fox disables or severely impairs the Firefox window manager's UI title bar minimisation behaviours.  

It would appear that forecast fox got a wee bit messy somewhere along the way and I would recommend, as a lowly osx user, to temporarily disable this particular plugins availability for FF3.  Yup.

\r

Updated

9 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Summary: CPU use very high on osx 10.4.11 powerbook dual intel : too hot to touch → CPU use very high on OS X 10.4.11 due to Forecastfox extension

Comment 6

9 years ago
Looks like it will be fixed in the next version of Forecastfox: http://ensolis.com/projects/forecastfox/ticket/84

Comment 7

9 years ago
According to bug 432028, this should be fixed if you update to a Firefox 3.0.2pre build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2008-07-10-04-mozilla1.9.0/

Or, you can try out a Forecastfox 0.9.7.7pre build, which contains a workaround for the Firefox bug:

http://forums.ensolis.com/viewtopic.php?p=565#p565
Depends on: 432028

Comment 8

9 years ago
Problem is still present with firefox 3.0.1 and forecastfox 0.9.7.7 (macos 10.5.4)
does not seem to happen on windows
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]

Comment 10

7 years ago
Does not seem to have the problem here, with my current profile.
Firefox 3.6.10, ForecastFox Weather 2.0.2, MacOS 10.6.4
(Reporter)

Comment 11

7 years ago
I hadn't looked back but upon receipt of action required I installed latest FCF weather in my current env - 10.5.8 and FF 3.6.11 and have had no issues.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.