Closed Bug 443035 Opened 12 years ago Closed 12 years ago

Some Address Book functions are disabled when the abResultsTree has focus

Categories

(MailNews Core :: Address Book, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1a1

People

(Reporter: pi, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: version 3.0a2pre (2008070114)

I just noticed this today after checking out and rebuilding Thunderbird.

When I click on a card in the abResultsTree, New Card List and Delete are grayed out and I am unable to delete a card through the GUI or by using the delete button.  I can delete cards through a script.  Additionally, Properties in the context menu for cards does not work.

There were no errors in the Error Console.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird (the lastest nightly) and the Address Book
2. Select a card
Actual Results:  
New Card List and Delete are grayed out and Properties in the context menu doesn't work.

Expected Results:  
The three commands should work as normal.

In addressbook.js:
function CommandUpdate_AddressBook()
{
  goUpdateCommand('cmd_delete');
  goUpdateCommand('button_delete');
  goUpdateCommand('cmd_newlist');
}
The problems I noticed were with these three commands.
The problem is the command controller for the results pane is never getting registered. In bug 437619 I moved the gAbResultsTree initialisation from OnLoad functions to SetAbView(). This caused gAbResultsTree to be null at the SetupAbCommandUpdateHandlers stage.

As we never clear gAbResultsTree, we can just do the addition of the command handler once we get it in SetAbView.
Assignee: nobody → bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #327689 - Flags: superreview?(bienvenu)
Attachment #327689 - Flags: review?(bienvenu)
Blocks: 437619
Keywords: regression
Comment on attachment 327689 [details] [diff] [review]
[checked in] The fix

one nit - SetupAbCommandUpdateHandlers only really initializes the DirPaneController, i.e., a single handler, so its name might be changed to SetupDirPaneController or you could even inline that code in the three places it's used, across TB and SM.
Attachment #327689 - Flags: superreview?(bienvenu)
Attachment #327689 - Flags: superreview+
Attachment #327689 - Flags: review?(bienvenu)
Attachment #327689 - Flags: review+
Comment on attachment 327689 [details] [diff] [review]
[checked in] The fix

I've checked this in without addressing the nits - I'll do those in a follow up patch.
Attachment #327689 - Attachment description: The fix → [checked in] The fix
I took a look at the SetupAbCommandUpdateHandlers function calls. The addressbook-panel one isn't actually required (as the panel doesn't have a dir tree), and the other two calls can just be replaced in-line.

I guess at some stage, it'll be a good idea to centralise the dir pane functions into one file as well, but that's definitely another bug ;-)
Attachment #327788 - Flags: superreview?(bienvenu)
Attachment #327788 - Flags: review?(neil)
Comment on attachment 327788 [details] [diff] [review]
[checked in] Follow-up - remove SetupAbCommandUpdateHandlers

thx, looks good.
Attachment #327788 - Flags: superreview?(bienvenu) → superreview+
Attachment #327788 - Flags: review?(neil) → review+
Attachment #327788 - Attachment description: Follow-up - remove SetupAbCommandUpdateHandlers → [checked in] Follow-up - remove SetupAbCommandUpdateHandlers
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1a1
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.