qm-win2k3-pgo01 is failing reftests for bug 199692

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
a month ago

People

(Reporter: lsblakk, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

The test cases for this bug are being extremely noisy on qm-win2k3-pgo01:

*** 12174 ERROR FAIL | Element from doubly nested iframe returned is from
calling document | got [object HTMLHtmlElement], expected [object
HTMLIFrameElement] | /tests/content/html/document/test/test_bug199692.html
*** 12172 ERROR FAIL | Hit testing should bypass hidden elements. | got [object
HTMLIFrameElement], expected [object HTMLDivElement] |
/tests/content/html/document/test/test_bug199692.html
*** 12166 ERROR FAIL | (327,313) IDs should match (upper left corner of
textbox) | got [object HTMLIFrameElement], expected [object HTMLInputElement] |
/tests/content/html/document/test/test_bug199692.html

For example.

There are almost 70 lines of errors like this from yesterdays builds and
already 21 today.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Of course now I realize I have no idea what the problem is and it's going to be hard to tackle.

Lukas, are you able to temporarily take over the box and reproduce the failures by running that mochitest on its own? Or by copying the build off the box and running the build locally?
I can try to grab the next build when it is done.  Each build clobbers the previous so all we have is the logs - but I can copy the next build for sampling and try running it locally.

Roc:

Is this something you (or whomever owns this test) can investigate? Lukas is trying to chase down intermittent problems on a whole bunch of unittests, so wont have time to do all these local steps to reproduce for all of these intermittent unittests.

If it helps, we could send you the objdir?

Also, what info should be added to the logs to make this kinda debugging easier in future?
If the build is published somewhere, that will help.

But sometimes we can't reproduce the problem using the same build because it's a problem specific to the test machine. In that case we have no choice but to call on people who have access to that machine to help.

Well, unless bug 438954 is fixed, which is the ultimate solution to all of this.
This has not been an issue since the move - resolving.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

11 years ago
this is now happening on tinderbox for 3 builds in a row
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Main failing box is
WINNT 5.2 mozilla-central qm-win2k3-moz2-01 dep unit test
but
WINNT 5.2 mozilla-central qm-win2k3-03 dep unit test
had it too.

Comment 8

11 years ago
The latest tinderbox results for qm-win2k3-moz2-01 dep unit test seems to indicate all tests for 199692 passing. I clobbered my mc build and couldn't reproduce any test failures.

If I can get binaries for a failing build, I can try to see what's going wrong, but I can't reproduce the failures locally, so I'm not sure what can be done...
This bug was for qm-win2k3-pgo01 which is now fx-win32-1.9-slave09 (pgo01), and is no longer failing this reftest.  If there are issues with reftest 199692 on other machines, please open a new bug.

Closing.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
Whiteboard: [orange]
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.